Лабораторная работа N 2. Использование МВТУ для анализа устоичивости САР.

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 2
АНАЛИЗ УСТОЙЧИВОСТИ И КОРРЕКЦИЯ САР В СРЕДЕ ПК "МВТУ"
ПО ЧАСТОТНЫМ ХАРАКТЕРИСТИКАМ И ПО ПОЛЮСАМ

Москва, 2001 г.

Цель работы:
  • ознакомление с дополнительными возможностями ПК "МВТУ";
  • освоение основных процедур работы в режиме АНАЛИЗ, включая:
    - подготовку структурной схемы САР для расчета АФЧХ;
    - расчет и построение графиков различных амплитудно-фазовых частотных характеристик (ЛАХ, ФЧХ, годограф Найквиста и др.);
    - анализ устойчивости замкнутой САР по амплитудно-фазовым частотным характеристикам разомкнутой САР, используя график годограф Найквиста или одновременное рассмотрение графиков ЛАХ и ФЧХ;
    - анализ устойчивости разомкнутых и замкнутых САР с использованием частотного критерия Михайлова;
    - расчет коэффициентов, полюсов и нулей передаточных функций и определение устойчивости по теоремам Ляпунова (по полюсам или по собственным числам);
  • анализ устойчивости САР ядерного реактора с использованием частотных критериев (критерии Найквиста и Михайлова) и по теоремам Ляпунова (по полюсам) с последующей коррекцией параметров САР.

Содержание:

  • Введение
  • 1. ОСНОВНЫЕ МЕТОДЫ И ПРОЦЕДУРЫ РАБОТЫ В РЕЖИМЕ АНАЛИЗ
    • 1.1. Анализ амплитудно-фазовых частотных характеристик
    • 1.2. Определение полюсов, нулей и коэффициентов передаточных функций
    • 1.3. Построение графиков частотных характеристик ряда типовых звеньев
  • 2. АНАЛИЗ УСТОЙЧИВОСТИ И КОРРЕКЦИЯ САР ЯДЕРНОГО РЕАКТОРА ПО АМПЛИТУДНО-ФАЗОВЫМ ЧАСТОТНЫМ ХАРАКТЕРИСТИКАМ

Загрузить бесплатную версию "МВТУ"(3.4 Мб)


Лабораторная работа N 2. Использование МВТУ для анализа устоичивости САР.

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 2
АНАЛИЗ УСТОЙЧИВОСТИ И КОРРЕКЦИЯ САР В СРЕДЕ ПК "МВТУ"
ПО ЧАСТОТНЫМ ХАРАКТЕРИСТИКАМ И ПО ПОЛЮСАМ

Москва, 2002 г.

Цель работы:

  • ознакомление с дополнительными возможностями ПК "МВТУ";
  • освоение основных процедур работы в режиме АНАЛИЗ, включая:
    • подготовку структурной схемы САР для расчета АФЧХ;
    • расчет и построение графиков различных амплитудно-фазовых частотных характеристик (ЛАХ, ФЧХ, годограф Найквиста и др.);
    • анализ устойчивости замкнутой САР по амплитудно-фазовым частотным характеристикам разомкнутой САР, используя график годограф Найквиста или одновременное рассмотрение графиков ЛАХ и ФЧХ;
    • анализ устойчивости разомкнутых и замкнутых САР с использованием частотного критерия Михайлова;
    • расчет коэффициентов, полюсов и нулей передаточных функций и определение устойчивости по теоремам Ляпунова (по полюсам или по собственным числам);
  • анализ устойчивости САР ядерного реактора с использованием частотных критериев (критерии Найквиста и Михайлова) и по теоремам Ляпунова (по полюсам) с последующей коррекцией параметров САР.

ВВЕДЕНИЕ

В лабораторной работе № 1 Вами рассмотрен ряд процедур работы в среде ПК "МВТУ" применительно к основному режиму анализа динамических процессов в управляемых технических системах, а именно, к режиму МОДЕЛИРОВАНИЕ.
Для более глубокого анализа динамических характеристик систем автоматического регулирования (САР) широко используются методы, основанные на амплитудно-фазовых частотных характеристиках системы (ЛАХ, ФЧХ, годографы различного типа и др.). Поэтому в ПК "МВТУ" реализован новый режим работы - АНАЛИЗ, одна из опций которого позволяет определить вышеперечисленные амплитудно-фазовые частотные характеристики большинства САР.
Для чисто линейных САР численные алгоритмы, реализованные в ПК "МВТУ", позволяют вычислить амплитудно-фазовые частотные характеристики (ЛАХ, ФЧХ, годограф Найквиста и др.) в "классическом" виде (по общеизвестным формулам из курса "Управление в технических системах"). Примерно аналогичный подход для расчета амплитудно-фазовых частотных характеристик в линейных САР реализован в известных зарубежных ПК SIMULINK, VisSim и др.
Для определения амплитудно-фазовых частотных характеристик нелинейных САР в малой окрестности стационарного состояния (нулевые начальные условия) или какого-то динамического состояния (ненулевые начальные условия) необходимо предварительно выполнить линеаризацию уравнений динамики САР. Процедура линеаризации уравнений может быть выполнена либо автоматически (программным комплексом), либо "вручную" (Пользователем) на листе бумаги... Вышеуказанные зарубежные ПК "предоставляют" Пользователю только 2-ой вариант...
Для многих нелинейных САР (не содержащих типовых нелинейных блоков с зоной нечувствительности) расчет частотных характеристик в среде ПК "МВТУ" выполняется с использованием численной линеаризации динамической модели САР, выполняемой автоматически (расчетным ядром ПК) в окрестности базовой точки.

(к содержанию)

1. ОСНОВНЫЕ МЕТОДЫ И ПРОЦЕДУРЫ РАБОТЫ В РЕЖИМЕ АНАЛИЗ

1.1. Анализ амплитудно-фазовых частотных характеристик

Методы и процедуры, обеспечивающие в ПК "МВТУ" режим работы АНАЛИЗ, будут рассмотрены в процессе выполнения дополнительного задания к рассмотренной в лабораторной работе № 1 демонстрационно-ознакомительной задаче. Сформулируем задачи, которые необходимо решить в процессе анализа АФЧХ САР, структурная схема которой создана Вами в лабораторной работе № 1 и сохранена на жестком диске:

  • исследовать на устойчивость исходную САР с использованием критерия Найквиста по годографу АФЧХ и по совместному рассмотрению ЛАХ - ФЧХ;
  • исследовать на устойчивость скорректированную САР с использованием критерия Найквиста по годографу АФЧХ и по совместному рассмотрению ЛАХ - ФЧХ, определив запасы по фазе и амплитуде;
  • исследовать на устойчивость исходную и скорректированную САР с использованием критерия Михайлова.
Поскольку структурная схема задачи (с исходными данными) была сохранена Вами на жестком диске, откройте эту задачу (проект), используя стандартные интерфейсные процедуры ПК "МВТУ". Необходимо заметить, что внешний вид структурной схемы в открывшемся проекте возможно отличается от того, который Вы сохраняли ранее... Если Вы желаете восстановить прежний вид, необходимо отключить опцию Рисовать обрамление в меню Стиль.
Этап 1 - исследование устойчивости исходной САР.
Переместите курсор на закладку Субструктуры и однократным щелчком левой клавиши "мыши" инициализируйте одноименный каталог в Общетехнической библиотеке типовых блоков. Перенесите в Схемное Окно 2 блока В память и проведите к ним линии связи, как это показано на рис. 1.1.
Внимание: типовой блок В память (и Из памяти тоже) в "Линейке" типовых блоков имеет оригинальную пиктограмму, а при переносе его в Схемное окно его изображение - текст (по умолчанию переменные имеют имена Y1, Y2 и т.д.).

Рис. 1.1

Типовые блоки В память и Из памяти предназначены, в основном, для реализации "беспроводной" передачи данных, используя механизм именованных переменных. Можно считать блок В память "передатчиком", блок Из памяти - "приёмником". Однако, в режиме АНАЛИЗ типовой блок В память используется для другой цели...
Переместите курсор на 1-ый блок В память (с текстом Y1), откройте его диалоговое окно и введите в верхней строке новое имя переменной, например, Вход. Точкой подключения 1-го блока В память к линии связи между блоками Управляющее воздействие и Главное сравнивающее устройство, а также именем переменной (Вход) задана точка приложения единичного гармонического воздействия: sin(w×t). Закройте диалоговое окно 1-го блока и повторите вышеописанное для 2-го блока В память, присвоив новой переменной любое "оригинальное" имя, например, Выход. Точка подключения 2-го блока В память и имя переменной (Выход) задают точку выхода при расчете амплитудно-фазовых частотных характеристик. Выполните оформление поясняющих подписей (щелчок правой клавишей "мыши" по блоку, далее опция Свойства и далее ...) и структурная схема САР примет вид, подобный рис. 1.1.
Проверьте, что параметры всех блоков в структурной схеме соответствуют исходным (в т.ч. коэффициент усиления в блоке Интегратор равен 1.0). Выполните "контрольное" моделирование и убедитесь, что переходной процесс расходящийся.
Известно, что критерий Найквиста позволяет оценить устойчивость (или неустойчивость) замкнутой линейной САР (с единичной Главной обратной связью) по АФЧХ разомкнутой САР. Поэтому, откройте диалоговое окно блока Сравнивающее устройство (выполняющего роль Главного сравнивающего устройства) и разомкните Главную обратную связь, установив 2-й весовой коэффициент равным нулю.
Выполните моделирование и убедитесь, что вид переходного процесса типичен для САР, находящихся на апериодической границе устойчивости (один нулевой полюс).
Переместите курсор на надпись Анализ в командном меню и сделайте щелчок "мышью". В открывшемся меню выберите опцию - Частотный анализ, щелкнув по ней левой клавишей "мыши". Откроется диалоговое окно Параметры частотного анализа. Введите значения первых 3-х параметров такими же, как на рис. 1.2. Остальные параметры оставьте без изменения.

Рис. 1.2

В диалоговом окне Параметры частотного анализа параметрами Начальная частота и Конечная частота задаются границы частотного диапазона (в рад/с), а параметром Число точек вывода - количество расчетных точек, равномерно распределенных (в логарифмическом масштабе) внутри частотного диапазона.
Значения параметров полей Приращения для Якобиана используются в расчете АФЧХ при автоматической линеаризации САР, а в чисто линейных системах расчет частотных характеристик не использует данных по относительным и абсолютным приращениям для Якобиана. Начинающему Пользователю рекомендуется использовать эти параметры "по умолчанию". Значения "по умолчанию" полей Приращения для Якобиана установлены из личного практического опыта авторов ПК "МВТУ"...
Переместите курсор на кнопку Характеристик и выполните щелчок левой клавишей "мыши": создастся графическое окно с заголовком Частотные характеристики и также изменится форма диалогового окна Параметры частотного анализа (см. рис. 1.3). Переместите в этом диалоговом окне курсор на крайнюю левую кнопку (с символом " + ") и выполните два щелчка левой клавишей "мыши": в таблице появятся две новые строки с номерами 1 и 2.
Переместите курсор на ячейку Входы 1-ой строки, выполните щелчок левой клавишей "мыши", нажмите на появившуюся в этой ячейке таблицы специальную кнопку и из списка переменных выберите Вход. Повторите аналогичные действия для ячейки Входы 2-й строки таблицы.
По аналогии с предыдущим заполните 2-й и 3-й столбцы таблицы (см. рис. 1.4).

Рис. 1.3
Рис. 1.4

Заполнив по инструкции диалоговое окно Параметры частотного анализа, Вы задали следующее: рассчитать Lm(w) (ЛАХ) и f(w) (ФЧХ) разомкнутой САР, если:

  • Начальная частота - 0.01 с - 1;
  • Конечная частота - 1000 с - 1;
  • Число точек вывода - 250 (равномерно в логарифмическом масштабе);
  • Относительное приращение для Якобиана - 0.001 (установлено по умолчанию);
  • Абсолютное приращение для Якобиана - 10 - 6 (установлено по умолчанию);
  • Входы - переменная Вход (одна и та же);
  • Выходы - переменная Выход (одна и та же).
Переместите курсор на кнопку Расчет и сделайте щелчок левой клавишей "мыши": начнется расчет частотных характеристик (кнопка Расчет имеет "блеклый" шрифт, т.е. она неактивна) и отображение результатов в специальном графическом окне, причем автоматически изменятся заголовок графика и подписи под осями координат. Через ~ 2...10 с расчет будет закончен и кнопка Расчет снова станет активной (четкий шрифт).
Переместите курсор в поле Графического окна и выполните 2-х кратный щелчок левой клавишей "мыши": данное Графическое окно перемасштабируется. Используя опции Графического окна (вызов "всплывающего" меню - однократным щелчком правой клавиши "мыши") установите следующие параметры оси ординат: Min Y - - 270; Max Y - + 90; Количество делений - 4. Если Вы выполните дополнительное оформление Графического окна, то получите вид, близкий к рис. 1.5.
Вид графиков на рис. 1.5 показывает, что фазовая характеристика пересекает линию - 180° о вроде бы немного раньше, чем характеристика Lm(w) пересекает линию 0 дБ. Уточним то, что видим... Переместите курсор в поле Графического окна, выполните щелчок правой клавишей "мыши" и выберите опцию Список (щелчок левой клавишей "мыши"): окно графиков заменится таблицей данных расчета. Прокруткой таблицы найдите строку, соответствующую lg(w) = 1.0413 (см. рис. 1.6), и убедитесь, что Lm(w) > 0 (0.141233), а фазовый сдвиг f(w) < -180º (-184.6). Следовательно, при замыкании САР единичной обратной связью она будет неустойчивой, что и показал ранее (в Лаб. Раб. № 1) график переходного процесса при исходных параметрах САР.

Рис. 1.5
Рис. 1.6
Верните предыдущий вид окна График - ЛАХ, ФЧХ (щелчок правой клавишей "мыши" в поле таблицы, затем щелчок левой клавишей "мыши" по опции Список).
Перенесите курсор на кнопку очистки таблицы Входы-Выходы-Характеристика (третья слева в окне Параметры частотного анализа) и выполните щелчок левой клавишей "мыши": диалоговое окно станет таким же, как и рис. 1.3. Закройте графическое окно с заголовком ЛАХ, ФЧХ (щелчок по системной кнопке в правом верхнем угле окна). Перенесите курсор на кнопку Годографов и выполните щелчок левой клавишей "мыши": появится новое графическое окно с заголовком Годографы.
Переместите курсор на крайнюю левую кнопку (с символом " + ") и выполните один щелчок левой клавишей "мыши": появится номер строки в таблице. Переместите курсор на ячейку Входы строки, выполните щелчок левой клавишей "мыши", нажмите на появившуюся в этой ячейке таблицы специальную кнопку и из списка переменных выберите Вход. Повторите аналогичные действия для ячейки Выходы и выберите переменную Выход. В ячейке Характеристика выберите вид годографа - Найквиста. Вид заполненной таблицы должен быть таким же, как и на рис. 1.7.

рис. 1.7.

Выполните щелчок левой клавишей "мыши" по кнопке Расчет: начнется расчет годографа АФЧХ (называемого в ПК "МВТУ" годографом Найквиста), а в Графическом окне - отображение результатов расчета.
Используя опцию Свойства командное меню Графического окна, приведите изображение графика годографа к такому же виду, как и на рис. 1.8.
Из критерия Найквиста известно, что САР, находящаяся на апериодической границе устойчивости в разомкнутом состоянии, станет устойчивой при ее замыкании единичной Главной обратной связью, если годограф АФЧХ не охватывает на комплексной плоскости "точку Найквиста" (-1, 0(i). Поэтому рассмотрим более "внимательно" поведение линии годографа в окрестности точки (-1, 0·i). Для этого, используя еще раз опцию Свойства командного меню Графического окна, приведите изображение графика годографа к такому же виду, как и на рис. 1.9.

Рис. 1.8
Рис. 1.9
Так как линия годографа разомкнутой САР на рис. 1.9 без сомнения охватывает точку (-1, 0·i), то резюме: исходная САР в замкнутом состоянии будет неустойчива.

Этап 2 - исследование устойчивости скорректированной САР.
Закройте диалоговое окно Параметры частотного анализа, щелкнув левой клавишей "мыши" по кнопке Да: на экране монитора снова появится Схемное Окно.
Измените коэффициент k1 в блоке W_1(s) на 0.35, что соответствует оптимальному значению (определенному в демонстрационно-ознакомительной задаче).
Переместите курсор на командную кнопку [image] Старт и сделайте щелчок "мышью": произойдет инициализация всех блоков структурной схемы. Далее можно и не считать переходной процесс, так как вся информация о структурной схеме получена и можно проводить расчет частотных характеристик. Переместите курсор на командную кнопку [image] Стоп и сделайте щелчок "мышью": расчет будет прерван, так и не начавшись.
Переместите курсор на надпись Анализ в командном меню, сделайте однократный щелчок "мышью" и в меню опять выберите опцию Частотный анализ. В открывшемся диалоговом окне Параметры частотного анализа не требуется переустанавливать параметры, так как они сохранены автоматически. Запустите расчет годографа (таким же образом, как Вы выполнили это выше). Сделайте график годографа более "симпатичным", изменив параметры осей координат Графического окна (см. рис. 1.10).
Еще раз измените параметры осей координат Графического окна (см. рис. 1.11). Линия годографа разомкнутой САР на рис. 1.11 без сомнения не охватывает точку (-1, 0·i). Вывод: скорректированная САР в замкнутом состоянии будет устойчива.

Рис. 1.10
Рис. 1.11
Перенесите курсор на кнопку очистки таблицы Входы-Выходы-Характеристика и выполните щелчок левой клавишей "мыши": диалоговое окно станет таким же, как и рис. 1.3. Закройте графическое окно с заголовком Годографы. Перенесите курсор на кнопку Характеристик и выполните однократный щелчок левой клавишей "мыши": появится новое графическое окно с заголовком Частотные характеристики.
Переместите в диалоговом окне Параметры частотного анализа курсор на крайнюю левую кнопку (с символом " + ") и выполните два щелчка левой клавишей "мыши": в таблице появятся две новые строки с номерами 1 и 2.
Переместите курсор на ячейку Входы 1-ой строки, выполните щелчок левой клавишей "мыши", нажмите на появившуюся в этой ячейке таблицы специальную кнопку и из списка переменных выберите Вход. Повторите аналогичные действия для ячейки Входы 2-й строки таблицы. По аналогии с предыдущим заполните 2-й и 3-й столбцы таблицы. Вид заполненного графического будет таким же, как и на рис. 1.4.
Переместите курсор на кнопку Расчет и сделайте щелчок левой клавишей "мыши": начнется расчет частотных характеристик и отображение результатов в специальном графическом окне, причем снова автоматически изменятся заголовок графика и подписи под осями координат.
Переместите курсор в поле Графического окна, выполните щелчок правой клавишей "мыши", выберите опцию Свойства и установите в диалоговом окне Настройка параметры оси ординат графика, как это выполнено на рис. 1.12.

Рис. 1.12

Из критерия Найквиста известно, что САР, находящаяся на апериодической границе устойчивости в разомкнутом состоянии, станет устойчивой при ее замыкании единичной Главной обратной связью, если график ЛАХ пересекает линию 0 дБ раньше, чем график ФЧХ линию - 180°. Анализ графиков f(w) и Lm(w) показывает, что при замыкании единичной обратной связью САР станет устойчивой.
Используя опции Графического окна переведите его в режим Список и определите запасы по фазе (в градусах) и амплитуде (в дБ). Эти запасы должны составлять ~ 86 о и ~ 8.2 дБ, соответственно (см. рис. 1.13 и рис. 1.14). Запас по фазе достаточен, однако крайне малый запас по амплитуде (должно быть ~ 30...40 дБ) обосновывает "не очень хорошее" качество переходного процесса в демонстрационно-ознакомительной задаче при k1 = 0.35.

Рис. 1.13
Рис. 1.14

Перенесите курсор на кнопку очистки таблицы Входы-Выходы-Характеристика и выполните щелчок левой клавишей "мыши": диалоговое окно станет таким же, как и рис. 1.3. Закройте графическое окно с заголовком ЛАХ, ФЧХ (однократный щелчок по системной кнопке в правом верхнем угле окна).
Закройте диалоговое окно Параметры частотного анализа, щелкнув левой клавишей "мыши" по кнопке Да: на экране монитора снова появится Схемное Окно.

Этап 3 - анализ устойчивости САР с использованием критерия Михайлова.
Известно, что критерий Михайлова основан на анализе частотных свойств характеристического полинома D(s) замкнутой системы при подстановке s = i·w . Если годограф Михайлова D(i·w) построен на комплексной плоскости, то для устойчивости замкнутой САР необходимо и достаточно, чтобы при изменении w от нуля до бесконечности линия годографа поочередно переходила из квадранта в квадрант в положительном направлении (против часовой стрелки), причем изменение аргумента Darg D(i·w) = n· p/2, где n - порядок системы.
Замкните обратную связь, введя в диалоговом окне блока Главное сравнивающее устройство значение 2-го весового коэффициента -1 (минус 1). Верните исходное значение коэффициента усиления в блоке c подписью W_1(s) (k1 = 1).
Выполните "контрольное" моделирование переходного процесса и убедитесь, что переходной процесс расходящийся, следовательно исходная САР неустойчива.
При открытии диалогового окна Параметры частотного анализа его вид будет таким же, как и на рис. 1.2. Переместите курсор на кнопку Годографов и выполните щелчок левой клавиши "мыши": появится графическое окно с заголовком Годографы и кнопка Годограф Михайлова станет активной (шрифт текста в кнопке изменит цвет с блеклого на черный).
Выполните щелчок левой клавиши "мыши" по кнопке Годограф Михайлова: в Графическом окне начнется отображение результатов расчета. По завершении расчета посредством командного меню Графического окна и опции Свойства измените параметры осей координат на графике годографа Михайлова, так как это выполнено на рис. 1.15.
Анализ графика на рис. 1.15 показывает, что при изменении w от нуля до бесконечности изменение аргумента Darg D(i·w) = 4·p/2 (так как порядок САР равен 4, а цена деления по оси абсцисс на 3 порядка больше, чем по оси ординат), однако поведение линии годографа в окрестности начала координат в таком масштабе графика не определимо. Выполните "вырезание" фрагмента графика в окрестности начала координат посредством изменения в диалоговом окне Настройка параметров осей координат (см. рис. 1.16).
Поведение кривой Михайлова на рис. 1.16 показывает, что последовательный переход из квадранта в квадрант не соблюдается: точка (1, 0) при (w = 0 -> 1-ый квадрант -> 2-ой квадрант -> 1-ый квадрант -> 4-ый квадрант.
Резюме: исходная САР неустойчива.

Рис. 1.15
Рис. 1.16
Закройте диалоговое окно Параметры частотного анализа (щелчок "мышью" по кнопке Да). Измените значение k1 (k1 = 0.35). Выполните "контрольный" расчет переходного процесса и убедитесь, что его вид соответствует устойчивому процессу...
Откройте снова диалоговое окно Параметры частотного анализа. Выполните щелчок левой клавишей "мыши" по кнопке Годографов: снова откроется специальное Графическое окно с заголовком Годографы.
Выполните щелчок левой клавиши "мыши" по кнопке Годограф Михайлова: в Графическом окне начнется отображение результатов расчета. По завершении расчета посредством командного меню Графического окна и опции Свойства измените параметры осей координат на графике годографа Михайлова, так как это выполнено на рис. 1.17. Вид кривой Михайлова на рис. 1.17 показывает, что при изменении w от нуля до бесконечности изменение аргумента Darg D(i·w) = 4·p/2однако поведение линии годографа в окрестности начала координат в этом масштабе графика также не определимо. Выполните "вырезание" фрагмента графика в окрестности начала координат посредством изменения в диалоговом окне Настройка параметров осей координат (см. рис. 1.18).

Рис. 1.17
Рис. 1.18
Поведение кривой Михайлова на рис. 1.18 показывает, что последовательный переход из квадранта в квадрант соблюдается: точка (1, 0) при w = 0 -> 1-ый квадрант -> 2-ой квадрант -> 3-ий квадрант -> 4-ый квадрант.
Резюме: скорректированная САР устойчива.
Закройте диалоговое окно Параметры частотного анализа (щелчок "мышью" по кнопке Да): на экране монитора снова Схемное окно (см. рис. 1.1).

(к содержанию)

1.2. Определение полюсов, нулей и коэффициентов передаточных функций

Верните исходное значение скоростной эффективности интегрирующего регулятора (k1 = 1). Разомкните Главную обратную связь (2-ой весовой коэффициент в Главном сравнивающем устройстве должен быть равен нулю). Выполните щелчок "мышью" по кнопке [image] Старт (структурная схема разомкнутой САР инициализировалась) и затем по кнопке [image] Стоп (моделирование прервано, так и не начавшись).
Откройте меню Анализ и выберите опцию Передаточные функции: откроется диалоговое окно Расчет передаточных функций (см. рис. 1.19). Переместите курсор на нижнюю справа красную стрелку и выполните щелчок "мышью": появится номер 1 в таблице Входы-Выходы. Переместите курсор на ячейку Входы в 1-ой строке таблицы (и единственной) и выполните щелчок "мышью", нажмите на появившуюся в этой ячейке таблицы специальную кнопку и из списка переменных выберите Вход. Повторите аналогичные действия для ячейки Выходы этой же строки таблицы и выберите переменную Выход. Заполнив таблицу, Вы подготовили данные для расчета полюсов, нулей и коэффициентов передаточной функции исходной САР в разомкнутом состоянии. Диалоговое окно будет иметь вид, аналогичный рис. 1.20.
Параметры диалоговых строк Относительное приращение для расчета Якобиана и Абсолютное приращение для расчета Якобиана можно оставить без изменений, так как в чисто линейных САР расчет параметров передаточных функций не использует данных по приращениям Якобиана. Использование данных по приращениям Якобиана имеет место в расчете параметров линеаризуемых САР (ПК "МВТУ" автоматически выполняет линеаризацию в окрестности базовой точки). Значения "по умолчанию" данных по приращениям Якобиана выбраны из личного опыта авторов ПК "МВТУ". Начинающему Пользователю рекомендуется использовать параметры "по умолчанию".

Рис. 1.19
Рис. 1.20
Переместите курсор на кнопку Расчет и выполните щелчок "мышью": практически мгновенно появится информационное окно с заголовков Результаты расчета параметров передаточных функций. В верхней части этого окна приведены результаты расчета коэффициентов Знаменателя и Числителей по возрастающим степеням s, а в нижней части - полюсы и нули передаточных функций САР (см. рис. 1.21).

Рис. 1.21

Учитывая, что эквивалентная передаточная функция рассматриваемой разомкнутой САР определяется не очень громоздким соотношением:

Прямой подстановкой исходных передаточных функций в это соотношение легко убедиться в правильности расчета программным комплексом "МВТУ" коэффициентов эквивалентной передаточной функции (выполните "ручной" расчет и сравните...).
Результаты расчета полюсов показывают, что исходная САР в разомкнутом состоянии находится на апериодической границе устойчивости, так как три полюса расположены в левой полуплоскости, а один - в начале координат.

Закройте последовательно информационное окно (щелчок "мышью" по "крестику" в верхнем правом угле окна) и затем диалоговое окно Расчет передаточных функций (щелчок "мышью" по кнопке Да в этом окне): на экране монитора снова Схемное окно.
Замкните Главную обратную связь. В диалоговом окне блока с подписью Вход измените имя переменной на новое - Input. Выполните щелчок "мышью" по кнопке [image] Старт (структурная схема замкнутой САР инициализировалась) и затем по кнопке [image] Стоп (моделирование прервано, так и не начавшись).
В командном меню Анализ выберите опцию Передаточные функции: откроется незаполненное диалоговое окно Расчет передаточных функций. Переместите курсор на нижнюю справа красную стрелку и выполните щелчок "мышью": появится номер 1 в таблице Входы-Выходы. Переместите курсор на ячейку Входы в 1-ой строке таблицы и выполните щелчок "мышью", нажмите на появившуюся в этой ячейке таблицы специальную кнопку и из списка переменных выберите Input. Повторите аналогичные действия для ячейки Выходы этой же строки таблицы и выберите переменную Выход. Заполнив таблицу, Вы подготовили данные для расчета полюсов, нулей и коэффициентов передаточной функции исходной САР в замкнутом состоянии. Диалоговое окно будет иметь вид, аналогичный рис. 1.22.

Рис. 1.22

Выполните щелчок по кнопке Расчет в этом диалоговом окне: в открывшемся информационном окне будут приведены результаты расчета параметров передаточной функции исходной САР в замкнутом состоянии. В верхней части информационного окна приведены результаты расчета коэффициентов Знаменателя и Числителей по возрастающим степеням s, а в нижней части - полюсы и нули передаточных функций САР (см. рис. 1.23).
В правильности расчета коэффициентов числителя и знаменателя передаточной функции замкнутой САР Вы можете убедиться, выполнив "ручной" расчет...
Анализ нижней таблицы в информационном окне еще раз подтверждает вывод об отсутствии устойчивости исходной САР в замкнутом состоянии: два действительных полюса расположены в левой полуплоскости, а два комплексно-сопряженных полюса - в правой полуплоскости.
Закройте последовательно информационное окно и затем диалоговое окно Расчет передаточных функций: на экране монитора снова Схемное окно.

Рис. 1.23

Измените значение коэффициента k1 на 0.35, при котором замкнутая САР несомненно должна быть устойчивой (см. рис. 1.11 или рис. 1.12).
Выполните щелчок "мышью" по кнопке [image] Старт (структурная схема замкнутой САР инициализировалась) и затем по кнопке [image] Стоп (расчет прерван, так и не начавшись).
Откройте диалоговое окно Расчет передаточных функций (в меню Анализ опция Передаточные функции). Выполните щелчок "мышью" по кнопке Расчет: откроется окно с результатами расчета для скорректированной САР (см. рис. 1.24).

Рис. 1.24

Анализ нижней таблицы в информационном окне (см. рис. 1.24) еще раз подтверждает вывод об устойчивости скорректированной САР в замкнутом состоянии: все четыре полюса расположены в левой полуплоскости (два отрицательных вещественных и два комплексно-сопряженных с отрицательной вещественной частью).
Закройте последовательно информационное окно и затем диалоговое окно Расчет передаточных функций: на экране монитора снова Схемное окно.
В диалоговом окне блока Вход измените имя переменной на старое - Вход.
Сохраните структурную схему на жесткий диск под "оригинальным" именем, так она Вам еще потребуется при выполнении лабораторной работы № 3...

(к содержанию)

1.3. Построение графиков частотных характеристик ряда типовых звеньев

Перед выполнением самостоятельного исследования частотных характеристик САР ядерного реактора (загляните в следующий раздел...) в качестве "легкой разминки" необходимо построить графики основных частотных характеристик для некоторых типовых звеньев и сравнить построенное с аналогичными графиками в лекциях по курсу "Управление в технических системах"...
Используя освоенные процедуры работы в режиме АНАЛИЗ, постройте для каждого из перечисленных ниже звеньев следующие частотные характеристики:
- графики годографов АФЧХ (годографов Найквиста);
- графики Lm(w) (ЛАХ);
- графики ФЧХ.

Рекомендуется задавать 600 расчетных точек, равномерно расположенных в логарифмическом масштабе в следующем диапазоне частот: от 10 - 3 до 10 3 с - 1 .

Список типовых звеньев, для которых необходимо построить вышеуказанные частотные характеристики:
1. Апериодическое звено 1-го порядка: К1 = 10; Т1 = 1 с; К2 = 10; Т2 = 10 с.
2. Колебательное звено: К1 = 10; Т1 = 1 с; ß1 = 0.8; К2 = 10; Т2 = 1 с; ß2 = 0.2.
3. Инерционно-дифференцирующее звено: t1 = 10 с; Т1 = 1 с; t2 = 10 с; Т2 = 10 с.

Рекомендуется строить требуемые частотные характеристики сразу для двух звеньев одного типа, что позволит выявить влияние варьируемого параметра (T или ß) на соответствующие графики (см. рис. 1.25).

Рис.1.25

Внимание: параллельно с исследованием АФЧХ вышеуказанных типовых звеньев в этом задании имеется возможность дополнительно "вспомнить" и переходные функции исследуемых типовых звеньев (при конечном в ремени моделировании 40 с), поэтому структурные схемы на рис. 1.25 содержат типовой блок Ступенчатое воздействие (с параметрами 0 0 1) и типовой блок Графическое окно...

(к содержанию)

2. АНАЛИЗ УСТОЙЧИВОСТИ И КОРРЕКЦИЯ САР ЯДЕРНОГО РЕАКТОРА ПО АМПЛИТУДНО-ФАЗОВЫМ ЧАСТОТНЫМ ХАРАКТЕРИСТИКАМ

В процессе выполнения лабораторной работы № 1 Вы сформировали структурную схему простейшей математической модели динамики САР ядерного реактора, внешний вид которой (с точностью до Ваших художественно-оформительских способностей) имел вид, приблизительно соответствующий структурной схеме на рис. 2.1.

Рис. 2.1

Подписи под блоками, которые формируют преобразование и отображение сигналов (см. рис. 2.1) дают минимальную информацию, по которой Вы должны (?!) "вспомнить" цель задания в предыдущей лабораторной работе и примененные Вами "нестандартные" методы ее решения ...
Поскольку задача (проект) Вами была сохранена на жестком диске, запустите ПК "МВТУ" и откройте "свою" модель динамики САР ЯР...
В данной части лабораторной работы Вам предстоит выполнить последовательно ряд этапов, направленных как на исследование частотных характеристик только ядерного реактора ("голый" реактор, реактор с местной обратной связью), так и на анализ САР ЯР в целом (исходной, а затем и скорректированной), включая анализ устойчивости САР ЯР с использованием частотного критерия Найквиста (различные варианты его формулировки) и по теоремам Ляпунова (по полюсам)...
Учитывая, что для расчета в среде ПК "МВТУ" амплитудно-фазовых частотных характеристик необходимо указать на структурной схеме точки приложения единичного гармонического воздействия и точки "выхода", Вы должны определить (самостоятельно) место расположения вышеуказанных точек и затем внести в структурную схему соответствующие добавления (а возможно и изменения)...

Примечания:
1. При выполнении ряда этапов Вам предстоит, в частности, исследовать АФЧХ "голого" реактора при двух значениях времени жизни мгновенных нейтронов и двух значениях доли запаздывающих нейтронов. Это потребует от Вас создания "дополнительной" модели кинетики для второго ядерного реактора, которую Вы можете расположить в свободном месте Схемного окна (например, в правом нижнем угле Схемного окна ( см. рис. 2.1).
2. При расчете и построении графиков АФЧХ рекомендуется задавать 700 расчетных точек, равномерно расположенных в логарифмическом масштабе в следующем диапазоне частот: от 10 - 3 до 10 4 с - 1 .

Для выполнения данной части лабораторной работы каждой подгруппе необходимо выполнить следующие этапы:

  • В рамках одного "сеанса" работы в режиме АНАЛИЗ рассчитать АФХЧ "голого" реактора (без любых обратных связей) при двух значениях времени жизни мгновенных нейтронов l = l исх (реактор типа РБМК) и l = 0.01· l исх (реактор типа ВВЭР для плавучих АЭС) и построить графики следующих характеристик:
    - годографы Найквиста (два годографа на одном графике);
    - логарифмические амплитудные характеристики (две ЛАХ на одном графике);
    - фазовые частотные характеристики (две ФЧХ на одном графике).
    Уяснить качественное влияние на вид этих характеристик значения времени жизни мгновенных нейтронов.
  • В рамках одного "сеанса" работы в режиме АНАЛИЗ рассчитать АФХЧ "голого" реактора (без любых обратных связей) при двух значениях доли запаздывающих нейтронов ß = ß исх (топливо U-235) и ß = 0.3·ß исх (топливо Pu-239) построить графики следующих частотных характеристик:
    - годографы Найквиста (два годографа на одном графике);
    - логарифмические амплитудные характеристики (две ЛАХ на одном графике);
    - фазовые частотные характеристики (две ФЧХ на одном графике).
    Уяснить качественное влияние на вид этих характеристик значения доли запаздывающих нейтронов.
  • В рамках одного "сеанса" работы в режиме АНАЛИЗ при исходных параметрах САР ЯР рассчитать АФХЧ "голого" реактора (без любых обратных связей) и АФЧХ ядерного реактора с местной обратной связью и построить графики следующих частотных характеристик:
    - годографы Найквиста (два годографа на одном графике);
    - логарифмические амплитудные характеристики (две ЛАХ на одном графике);
    - фазовые частотные характеристики (две ФЧХ на одном графике).
    Уяснить качественное влияние на вид этих характеристик отрицательной обратной связи по температуре топлива.
  • Выполнить оценку устойчивости исходной САР в разомкнутом и замкнутом состояниях, использую непосредственное вычисление полюсов соответствующих передаточных функций.
  • Выполнить "контрольное" моделирование при подаче управляющего воздействия u(t) = 0.05·1(t) и убедиться, что исходная САР в замкнутом состоянии либо неустойчива, либо имеет явно "плохое" качество переходного процесса.
  • В рамках одного "сеанса" работы в режиме АНАЛИЗ выполнить анализ устойчивости исходной замкнутой САР, используя критерий Найквиста в следующих вариантах его применения:
    - по годографу АФЧХ разомкнутой САР;
    - по одновременному рассмотрению ЛАХ и ФЧХ разомкнутой САР.
    Определить во сколько раз необходимо уменьшить скоростную эффективность привода регулирующего стержня, чтобы запас устойчивости по амплитуде составлял не менее 30 дБ, а запас по фазе - не менее 60°.
  • Выполнить коррекцию САР (уменьшить Кпр) и прямым моделированием убедиться, что при подаче управляющего воздействия u(t) = 0.05·1(t) скорректированная САР устойчива и имеет удовлетворительное качество переходного процесса.
  • В рамках одного "сеанса" работы в режиме АНАЛИЗ проверить устойчивость скорректированной замкнутой САР, используя критерий Найквиста в следующих вариантах его применения:
    - по годографу АФЧХ разомкнутой САР;
    - по одновременному рассмотрению ЛАХ и ФЧХ разомкнутой САР.
    Определить запасы устойчивости скорректированной САР по амплитуде и по фазе.
  • Выполнить проверку устойчивости скорректированной САР в замкнутом состоянии, использую непосредственное вычисление полюсов характеристического полинома замкнутой САР.
  • Определить аналитические выражения главной передаточной функции Ф(s) передаточной функции по возмущающему воздействию Фf(s).

Сохраните проект (задачу) на жесткий диск, так как он (проект) частично будет использован Вами при выполнении лабораторной работы № 3.

(к содержанию)