Лабораторная работа N 1. (Использование МВТУ)

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 1
ИСПОЛЬЗОВАНИЕ ПРОГРАММНОГО КОМПЛЕКСА "МОДЕЛИРОВАНИЕ В ТЕХНИЧЕСКИХ УСТРОЙСТВАХ" (ПК "МВТУ") ДЛЯ АНАЛИЗА ДИНАМИКИ ЛИНЕЙНЫХ И ЛИНЕАРИЗОВАННЫХ САР, ОПИСЫВАЕМЫХ В ПЕРЕМЕННЫХ "ВХОД - ВЫХОД"

Москва, 2002 г.

Цель работы:
  • ознакомление с возможностями программного комплекса "МВТУ" версия 3.0;
  • освоение процедур формирования структурной схемы САР и ее параметров;
  • освоение процедур работы в режиме МОДЕЛИРОВАНИЕ, включая: выбор метода и параметров интегрирования; вывод данных расчета и т.п.;
  • формирование структурной схемы САР простейшей модели ядерного реактора, описываемой в переменных "вход-выход";
  • определение устойчивости САР ядерного реактора прямым моделированием переходных процессов при подаче управляющего и возмущающего воздействий.

Содержание:

  • Введение
  • 1. ОБЩИЕ СВЕДЕНИЯ О ПРОГРАММНОМ КОМПЛЕКСЕ "МВТУ"
    • 1.1. Назначение, режимы работы, особенности и достоинства ПК "МВТУ"
    • 1.2. Запуск программного комплекса "МВТУ"
    • 1.3. Структура и состав ПК "МВТУ"
    • 1.4. Командное меню Главного Окна
    • 1.5. Панель инструментов Главного Окна
    • 1.6. Дополнительная панель инструментов
    • 1.7. "Линейка" типовых блоков
  • 2. КРАТКОЕ ОПИСАНИЕ ПРОЦЕДУР РАБОТЫ В ПК "МВТУ"
    • 2.1 Основные этапы работы в середе ПК "МВТУ"
    • 2.2 Демонстрационный пример по динамике САР ядерного реактора
    • 2.3 Демонстрационно-ознакомительная задача
      • 2.3.1 Исходные данные для ознакомительной задачи
      • 2.3.3 Ввод структурной схемы и исходных данных
      • 2.3.3 Моделирование переходных процессов и вариантные рассчеты
  • 3. САМОСТОЯТЕЛЬНОЕ ИССЛЕДОВАНИЕ САР ЯДЕРНОГО РЕАКТОРА ПРЯМЫМ МОДЕЛИРОВАНИЕМ ПЕРЕХОДНЫХ ПРОЦЕССОВ

      • Загрузить бесплатную учебную версию МВТУ (3.39 MB)


Лабораторная работа N 1. часть 1. Использование МВТУ.

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 1
часть 1
ИСПОЛЬЗОВАНИЕ ПРОГРАММНОГО КОМПЛЕКСА "МОДЕЛИРОВАНИЕ В ТЕХНИЧЕСКИХ УСТРОЙСТВАХ" (ПК "МВТУ") ДЛЯ АНАЛИЗА ДИНАМИКИ ЛИНЕЙНЫХ И ЛИНЕАРИЗОВАННЫХ САР, ОПИСЫВАЕМЫХ В ПЕРЕМЕННЫХ "ВХОД - ВЫХОД"

Москва, 2002 г.

Цель работы:

  • ознакомление с возможностями программного комплекса "МВТУ" версия 3.0;
  • освоение процедур формирования структурной схемы САР и ее параметров;
  • освоение процедур работы в режиме МОДЕЛИРОВАНИЕ, включая: выбор метода и параметров интегрирования; вывод данных расчета и т.п.;
  • формирование структурной схемы САР простейшей модели ядерного реактора, описываемой в переменных "вход-выход";
  • определение устойчивости САР ядерного реактора прямым моделированием переходных процессов при подаче управляющего и возмущающего воздействий

ВВЕДЕНИЕ

Высокие темпы развитие аппаратных средств вычислительной техники в последнее десятилетие обеспечили реальную возможность создания эффективных программных средств САПР, включая как традиционных средств САПР конструкторского направления (EUCLID, ACAD, КОМПАС и др.), так и "интеллектуальных" САПР, предназначенных для автоматизации наукоемких расчетов в обоснование основных показателей проектируемой установки, таких как безопасность, надежность и др.
К разряду "интеллектуальных" САПР относятся программно-инструментальные средства автоматизации динамических расчетов (АДР). Наиболее важным признаком автоматизации является удобство "сборки" из разнообразных модулей, каждый из которых решает ту или иную небольшую задачу, некоторой единой системы, решающей задачу более высокого уровня. В идеале полная программа расчета динамики - это многомерная сеть, в узлы которой автоматически подаются нужные программные модули из библиотеки моделирующих программ. В ней предусмотрена возможность расширения, замен и улучшения общей структуры и отдельных модулей.
Программно-инструментальные средства автоматизации динамических расчетов сложных технических систем позволяют: в десятки раз сократить время от разработки математической модели объекта до получения результатов моделирования; повысить надежность результатов расчетов; оптимизировать полученные решения, используя многовариантный анализ, и т.п. Средства АДР дают возможность Проектировщику сосредоточиться на решении основной задачи и не отвлекаться на разработку программ и алгоритмов. Именно в системах АДР появляется реальная возможность ясного вмешательства в те или иные фрагменты процесса счета и его изменения в соответствии с желанием Исследователя (в том числе и в режиме "on-line").
Наиболее общим подходом к созданию систем АДР, охватывающих очень широкий спектр областей применения (от технических до организационных), следует считать развитие методов структурного моделирования. К настоящему времени за рубежом разработан ряд программно-инструментальных средств для моделирования и анализа на ЭВМ динамических систем, в основе которых лежит метод структурного моделирования. Большинство из них представляет собой универсальные программные комплексы (ПК) с библиотеками типовых модулей общетехнического профиля (наиболее известные из них - SIMULINK, VisSim, MATRIXx , CTRL-C, EYSI-5).
В настоящее время из отечественных программно-инструментальных средств АДР наиболее развитым является программный комплекс "Моделирование в технических устройствах" (ПК "МВТУ"), созданный в МГТУ им. Н.Э. Баумана на кафедре "Ядерные реакторы и установки". ПК "МВТУ" по реализованным в нем ряду новых методов анализа, по интерфейсу Пользователя и, особенно, по численным алгоритмам интегрирования жестких динамических систем дифференциальных уравнений является альтернативой вышеуказанным зарубежным программным средствам АДР.
Эффективность использования ПК "МВТУ" показана как в учебном процессе МГТУ им. Н.Э. Баумана и ряда других технических университетов (при выполнении виртуальных лабораторных работ, в курсовом и дипломном проектировании), так и в ряде реальных проектных разработок Минатома РФ (разработка математической модели АСУ ТП энергоблока АЭС "БУШЕР"; расчетное обоснование ядерной безопасности ЯЭУ малой мощности для плавучей АЭС в переходных режимах и в проектных аварийных ситуациях; разработка математической модели динамики опытно-демонстрационной реакторной установки ОДУ БРЕСТ-300).

(к содержанию)

1. ОБЩИЕ СВЕДЕНИЯ О ПРОГРАММНОМ КОМПЛЕКСЕ "МВТУ"

1.1. Назначение, режимы работы, особенности и достоинства ПК "МВТУ"

Программный комплекс "Моделирование в технических устройствах" ("МВТУ") - современная среда интеллектуального САПР, предназначенная для детального исследования и анализа динамических процессов в ядерных и тепловых энергетических установках, в системах автоматического управления (САУ), в следящих приводах и роботах, в любых технических системах, описание динамики которых может быть реализовано методами структурного моделирования.
Может использоваться для моделирования нестационарных процессов в физике, в электротехнике, в динамике машин и механизмов, в астрономии и т.д., а также для решения нестационарных краевых задач (теплопроводность, гидродинамика и др).
Может функционировать в многокомпьютерных моделирующих комплексах, в том числе и в режиме удаленного доступа к технологическим и информационным ресурсам.

Программный комплекс "МВТУ" реализует следующие режимы работы:

  • МОДЕЛИРОВАНИЕ, обеспечивающий:
    • моделирование нестационарных процессов в непрерывных, дискретных и гибридных технических системах, в том числе и при наличии обмена данными (синхронный или асинхронный) с внешними программами и устройствами;
    • редактирование параметров структурной схемы и расчета в режиме "on-line";
    • расчет в реальном времени или в режиме масштабирования модельного времени;
    • рестарт, архивацию и воспроизведение результатов моделирования.
  • ОПТИМИЗАЦИЯ, позволяющий решать задачи:
    • параметрической оптимизации САУ и идентификации опытных данных;
    • cинтеза оптимальных регуляторов и оптимального управления в многокритериальной постановке при наличии ограничений на значения динамических переменных, управляющих воздействий, параметров элементов системы автоматического управления, функционалов качества.
  • АНАЛИЗ, обеспечивающий:
    • расчет амплитудно-фазовых частотных характеристик для любой линейной и большинства нелинейных систем (ЛАХ, ФЧХ, различные годографы и др.);
    • расчет коэффициентов, полюсов и нулей передаточных функций.
  • КОНТРОЛЬ И УПРАВЛЕНИЕ, позволяющий:
    • создавать электронные аналоги измерительных приборов и управляющих устройств для оперативного контроля и управления переходными процессами;
    • выполнять статистическую обработку сигналов (в том числе и внешних), основанную на быстром преобразовании Фурье.
  • СИНТЕЗ *, позволяющий:
    • синтезировать регуляторы с заданными характеристиками с помощью частотного и корневого методов.
* В настоящие время режим СИНТЕЗ проходит внутреннее тестирование и будет включен в свободно распостраняемую версию МВТУ ориентировочно в январе 2003 года.

Программный комплекс "МВТУ" имеет следующие достоинства:
  • открытость за счет реализации в ПК "МВТУ" нескольких механизмов обмена данными с внешними расчетными программами, а также за счет встроенного в ПК интерпретатора математических функций;
  • принцип вложенности структур (глубина вложенности неограниченная), что особо актуально при моделировании сложных динамических систем;
  • векторизация алгоритмов передачи и обработки данных за счет реализации линий связи типа "шина" данных и векторизации входов/выходов всех типовых блоков;
  • наличие наиболее полной Общетехнической и ряда Специализированных библиотек типовых блоков, в т.ч. библиотеки теплофизических свойств основных рабочих тел;
  • наличие библиотеки Контроль и управление, что позволяет формировать в ПК "МВТУ" панели (щиты) приборов для отображения и оперативного управления моделируемой системой в процессе расчета;
  • 16 алгоритмов интегрирования, включая 10 новых эффективных алгоритмов (5 явных и 5 неявных) для жестких систем дифференциальных уравнений;
  • функционирование в любой версии WINDOWS, наличие подробной контекстной справочной системы, эффективность в отраслевых разработках и учебном процессе.

    (к содержанию)

1.2. Запуск программного комплекса "МВТУ"

Запуск ПК "МВТУ" осуществляется файлом Mbty.exe, расположенным в подкаталоге BIN. В среде WINDOWS ПК "МВТУ" может быть запущен также посредством: кнопки Пуск и меню Программы или Выполнить; Проводника программ; специально созданной для запуска пиктограммы. Более подробная информация о способах запуска программ приводится в Инструкции Пользователя WINDOWS...Через 1...3 с после запуска на экране монитора появится заставка с фотографией главного корпуса МГТУ им. Н.Э. Баумана и реквизитами авторов ПК "МВТУ" и (см. рис. 1.1).

ЭКРАННАЯ КОПИЯ ЗАСТАВКИ ПК "МВТУ"

Рис. 1.1

Через 3...5 секунд на экране монитора появится Главное Окно программного комплекса "МВТУ" (см. рис. 1.2), где в верхней части Главного Окна - ленточное Командное меню, в центральной части - Панель инструментов (командных кнопок), а ниже - "Линейка" типовых блоков с соответствующими пиктограммами и закладками названий отдельных библиотек, сформированных по функциональному принципу.

ЭКРАННАЯ КОПИЯ ГЛАВНОГО ОКНА ПК "МВТУ"

Рис. 1.2

(к содержанию)

1.3. Структура и состав ПК "МВТУ"

Различные версии ПК "МВТУ" (профессиональная, демонстрационная, учебная, ограниченная учебная) имеет единую файловую структуру. На рис. 1. 3 представлена структура каталога МВТУ_3_0. Ядро ПК "МВТУ" размещено в подкаталоге BIN.
В подкаталоге DEMO размещено несколько подкаталогов с набором демонстрационных примеров из различных разделов техники. Подкаталог DOC содержит документ WinWord 2000 (расширение .doc) с Краткой Инструкцией Пользователя. Подкаталог PROJECTS предназначен для сохранения проектов (задач), которые будут созданы начинающим Пользователем (например, на стадии освоения процедур работы в среде ПК "МВТУ").
Примечание: допускается переименование или копирование каталога МВТУ_3_0, созданного при инсталляции ПК "МВТУ" на Вашем компьютере, в каталог с другим названием.

рис 1.3

Во всех версиях ПК "МВТУ" подкаталог BIN имеет практически одинаковую файловую структуру (см. рис. 1.4). В профессиональной версии перечень файлов с расширением .dll более полный за счет включения в ПК "МВТУ" дополнительных Специализированных библиотек типовых блоков.

рис 1.4

Расшифровка назначения подкаталога BMP и файлов.
Имя подкаталога или файла | Назначение подкаталога или файла или файла
BMP | Каталог, предназначенный для хранения оригинальных пиктограмм типовых блоков (созданных Пользователем) в bitmap-формате;
Mbty. еxe | Главный исполняемый файл, обеспечивающий: функционирование графического редактора и интерфейсных процедур; выбор и управление численными алгоритмами расчета и т.д.;
Mbty.dat | Файл, обеспечивающий "разрешение" запуска ПК "МВТУ";
UnInstal.exe | Исполняемый файл, обеспечивающий удаление ПК "МВТУ" (каталог на жестком диске и соответствующая папка в меню Программы оболочки WINDOWS);
About.dll | Дополнительный исполняемый файл, обеспечивающий вызов заставки ПК "МВТУ";
Hclib.dll | Вспомогательный исполняемый файл, обеспечивающий работу блоков Специализированной библиотеки Теплопроводность;
Kinlib.dll | Вспомогательный исполняемый файл, обеспечивающий работу Специализированной библиотеки Кинетика нейтронов;
robot.dll | Вспомогательный исполняемый файл, обеспечивающий расчетные процедуры Специализированной библиотеки Роботы;
Robotlib.dll | Вспомогательный исполняемый файл, обеспечивающий вызов и работу специализированного блока Многозвенный робот;
Statlib.dll | Вспомогательный исполняемый файл, обеспечивающий работу блоков Специализированной библиотеки Статистика;
Stdlib. dll | Дополнительный исполняемый файл, обеспечивающий работу Общетехнической библиотеки типовых блоков;
Vodalib. dll | Вспомогательный исполняемый файл, обеспечивающий работу ряда блоков Специализированной библиотеки Свойства;
Mbty. cnt | Вспомогательный файл справочной системы;
Mbty. hlp | Основной файл справочной системы;
Voda. tbl | Файл данных (электронная таблица) со свойствами воды и пара.

В подкаталог DEMO типовой комплектации ПК "МВТУ" включены файлы демонстрационных примеров, соответствующих как широко известным ("классическим") динамическим задачам, так и менее известным задачам из ряда технических дисциплин. Демонстрационные примеры отсортированы по отдельным подкаталогам (поддиректориям) в соответствии с используемыми методами анализа динамики систем автоматического управления или в соответствии с технической направленностью примеров, причем подкаталог ...\DEMO\ROBOT содержит внутри себя еще 2 подкаталога с демонстрационными примерами по динамике следящих приводов с непрерывным и цифровым (дискретным) управлением, соответственно.

Перечень подкаталогов и примеров.
Имя файла | Назначение демонстрационного примера
Подкаталог DEMO\ADAPT
adap_pi.mrj | Моделирование адаптивного ПИ-регулятора; *)
adap_pid.mrj | Моделирование адаптивного ПИД-регулятора; *)
Подкаталог DEMO\FREQUEN
fre_a_pi.mrj | Частотные характеристики при адаптивном ПИ-регулировании; *)
Подкаталог DEMO\IDENTIF
freqpar.mrj | Определение амплитуды и фазы АФЧХ управляемой САР;
ident_2.mrj | Определение параметров АФЧХ управляемой САР;
Подкаталог DEMO\LAB_WORK
lab83_11.mrj | Промежуточный этап демонстрационно-ознакомительной задачи из "Краткой Инструкции Пользователя";
lab83_21.mrj | Заключительный этап демонстрационно-ознакомительной задачи из "Краткой Инструкции Пользователя";
Подкаталог DEMO\MIXT
fas_port.mrj | Исследование нелинейной динамической системы 2-го порядка на фазовой плоскости; *)
int_vdp3.mrj | Моделирование уравнения Ван-дер-Поля при 3-х начальных условиях с использованием интерпретатора математических функций;
lorenz_3.mrj | Моделирование странного аттрактора Лоренца;
sbo_gork.mrj | Моделирование системы "самолет - б...я - осколки"; *)
vdp5_20.mrj | Моделирование "сверхжесткого" уравнения Ван-дер-Поля с использованием метода структурного моделирования;
vdp2_29.mrj | Моделирование "сверхжесткого" уравнения Ван-дер-Поля с использованием интерпретатора математических функций;
vdp2_29.mrj | Моделирование "сверхжесткого" уравнения Ван-дер-Поля с использованием интерпретатора математических функций;
wim.mrj | Моделирование широтно-импульсной модуляции;
Подкаталог DEMO\OPTIM
opt_pid.mrj | Синтез оптимального ПИД-регулятора по 3-м критериям;
opt_pidd.mrj | Коррекция ПИД-регулятора по 3-м критериям; Подкаталог DEMO\REACTORS
opt_pidd.mrj | Коррекция ПИД-регулятора по 3-м критериям;
Подкаталог DEMO\REACTORS
int_reak.mrj | Моделирование динамики простейшей САР ядерного реактора с использованием интерпретатора математических функций;
lab_83.mrj | Моделирование динамики САР ядерного реактора в режиме реального времени с учетом обратных связей и нелинейности характеристик стержня и привода СУЗ;
lad8reak.mrj | Моделирование динамики САР ядерного реактора при наличии управляющих и возмущающих воздействий с учетом обратных связей и нелинейности характеристики стержня СУЗ;
reak_lab.mrj | Исследование режима автоколебаний в релейном автоматическом регуляторе мощности реактора типа РБМК с использованием метода структурного моделирования;
Подкаталог DEMO\ROBOT
Подкаталог...\CONTIN | Моделирование динамики следящих приводов с непрерывным управлением (8 примеров);
Подкаталог...\DISKRET | Моделирование динамики следящих приводов с цифровым (дискретным) управлением (6 примеров).

Примечание. Примеры с меткой *) не моделируются в ограниченной учебной версии, так как в них число дифференциальных переменных превышает ограничение (не более 12 дифференциальных переменных).

(к содержанию)

1.4. Командное меню Главного Окна

Главное Окно программного комплекса "МВТУ" имеет следующие меню:

  • Файл:
    • Создать (F3)
    • Открыть (Ctrl + F3)
    • Сохранить... (F2)
    • Сохранить как ... (Ctrl + F2)
    • Протокол
    • Печать... (Ctrl + P)
    • Установки печати...
    • Выход
  • Опции:
    • Настройки...
    • Настройка палитры
    • Поиск блока...
    • Повторить поиск блока (Ctrl + R)
    • Поиск переменной...
    • Поиск переменной в области памяти...
    • Повторить поиск в области памяти...
    • Графики
    • Навигатор
    • Показать панели
    • Перемещать палитру
  • Стиль:
    • Шрифт подписи блока (Ctrl + F)
    • Цвет линий (Ctrl + C)
    • Фон блока (Ctrl + B)
    • Фон окна (Ctrl + W)
    • Подпись блока
    • Рисовать обрамление
    • Установить имена блоков
    • Очистить имена блоков
    • Очистить подписи блоков
  • Моделирование:
    • Начать (F9)
    • Останов (Shift + F9)
    • Расчет (Ctrl + F9)
    • Пауза
    • Параметры расчета...(F10)
    • Окно сообщений
    • Отладочная информация
    • Эмуляция расчета из файла
  • Оптимизация:
    • Расчет
    • Останов
    • Параметры...
    • Результаты...
  • Анализ:
    • Частотный анализ...
    • Передаточные функции
    • ? :
    • Содержание (F1)
    • О программе...
Примечания:
  1. Большинство опций Командного меню продублированы в Панели инструментов соответствующими командными кнопками.
  2. В ПК "МВТУ" нажатием клавиши F1 или посредством меню "?" и опции Содержание вызывается "навигатор" всей контекстной справочной системы, а нажатием комбинации клавиш Ctrl + F1 при выделенном типовом блоке вызывается справка по этому блоку.

Учитывая, что все интерфейсные команды нецелесообразно вносить в Командное меню Главного Окна, часть команд реализовано посредством:
- Дополнительной Панели инструментов, расположенной в верхней части Главного или субмодельного схемного окна (см. рис. 1.5) и обеспечивающей выполнение большинства команд и процедур редактирования структурной схемы;
- Дополнительного командного меню, вызов которого осуществляется нажатием правой клавиши "мыши" при расположении ее курсора в свободном месте схемного окна (Главного или субмодельного).
На рис. 1.5 на фоне Главного Схемного Окна представлено Дополнительное командное меню, содержащее 12 дополнительных интерфейсных опций, часть из которых (опции Сетка, Вставить субмодель, Добавить/Заменить блок, Непрерывная вставка блока, Выделение группы) фактически является дополнительными процедурами графического редактора ПК "МВТУ".
Оставшиеся семь опций Дополнительного командного меню обеспечивают:

Панель инструментов | включение/отключение командных кнопок Схемного окна;
Фон | замену однотонного фона схемного окна (по умолчанию белого) на "подложку" в bit-map формате, что позволяет придать структурной схеме вид, близкий к мнемосхемам на реальных пультах управления техническими объектами;
Копировать изображение | копирование в буфер содержимого Схемного окна для последующей вставки в другие документы, например, в текстовые документы WINWORD;
Внешние сигналы | описание внешних (по отношению к ПК "МВТУ") входных сигналов;
Параметры макроблока | задание Глобальных параметров проекта при активном Главном Схемном Окне или глобальных параметров макроблока (субмодели) при активном субмодельном схемном окне;
Приоритет проекта | ранжирование по "важности" проекта в случае моделирования в среде ПК "МВТУ" одновременно нескольких динамических задач (независимых или связных);
Показать алгебраические петли | вывод списка определяющих блоков с последующим выделением жирными линиями связи выявленных алгебраических контуров.

ИЛЛЮСТРАЦИЯ ДОПОЛНИТЕЛЬНОГО КОМАНДНОГО ОКНА

Рис. 1.5

(к содержанию)

1.5. Панель инструментов Главного Окна

Панель инструментов, расположенная в средней части Главного Окна, имеет специальные кнопки, реализующие команды и опции:
Название кнопки | Назначение кнопки
Новый | Открывает Схемное Окно нового проекта (задачи)
Открыть | Открывает окно считывания с диска ранее созданной структурной схемы динамической задачи (по умолчанию вызывается корневой каталог с указанием файлов, имеющих расширение . mrj)
Сохранить | Сохраняет структурную схему и параметры (по умолчанию файл с расширением . mrj), включая метод, параметры интегрирования, окна отображения результатов расчета и т.п.
Навигатор | Открывает окно Навигатора проекта
Список графиков | Открывает окно Списка графиков
Поиск блока | Открывает диалоговое окно Поиск блока в структурной схеме по ряду отличительных признаков (тип блока, название блока и т.п.)
Продолжить поиск блока | Продолжает поиск блоков в структурной схеме по выбранному отличительному признаку (тип блока, название блока и т.п. )
Поиск переменной | Открывает диалоговое окно Поиск переменной в структурной схеме по ряду отличительных признаков (имя глобальной переменной, источник переменной или ссылка на переменную)
Продолжить поиск переменной | Продолжает поиск переменной в структурной схеме по выбранному отличительному признаку (имя глобальной переменной, источник переменной или ссылка на переменную)
Параметры счета | Вызывает диалоговое окно выбора метода интегрирования, установки времени, шага интегрирования, точности и т.д.
Старт | Выполняет 1-й этап запуска проекта на счет, проводя инициализацию всех блоков и линий связи в схемных окнах проекта на "нулевом" шаге интегрирования
Стоп | Завершает расчет с сохранением в оперативной памяти параметров модели и состояния системы
Продолжить | Запускает сразу задачу (проект) на счет, если команда Старт не выполнялась; "дозапускает" задачу на счет, если команда Старт выполнялась; продолжает процесс моделирования до конечного времени, если он был прерван кнопкой (командой) Пауза
Пауза | Прерывает процесс расчета с сохранением в оперативной памяти параметров модели и текущего состояния системы
Параметры оптимизации | Открывает окно Параметры оптимизации
Расчет оптимальных параметров | Запускает на счет оптимизационную задачу
Стоп оптимизация | Прерывает расчет оптимизационной задачи
Результаты оптимизации | Выводит таблицу расчетов оптимизационной задачи
Справка | Открывает окно контекстной справочной системы ПК "МВТУ"
Выйти | Завершает сеанс работы в среде ПК с предложением сохранить текущую структурную схему

(к содержанию)

1.6. Дополнительная панель инструментов

Дополнительная панель инструментов, расположенная в верхней части Схемного Окна, имеет специальные кнопки, реализующие команды и опции:

Название кнопки | Назначение кнопки
Параметры макроблока | При активном Главном Схемном Окне открывает Окно глобальных параметров проекта (посредством Редактора Интерпретатора математических функций). При активном субмодельном схемном окне - окно глобальных параметров макроблока (субмодели)
Вырезать | Удаляет выделенный блок или фрагмент структурной схемы с сохранением его в Буфере Обмена
Копировать | Копирует выделенный блок или фрагмент структурной схемы в Буфер Обмена
Вставить | Копирует в Схемное Окно содержимое Буфера Обмена
Исключить блок | Выключает блок (группу блоков) из динамической модели (фон блока "окрашивается" черным цветом)
Включить блок | Включает ранее выключенный блок (или группу блоков) в динамическую модель (возвращает исходный фон блока)
Заморозить | Кнопка предназначена для поддержания (в процессе моделирования) постоянным сигнала на выходе динамического блока и равного начальному (ым) условию (ям) для данного блока
Разморозить | Кнопка отменяет команду Заморозить
Выделить все... | Выделяет полностью содержимое активного Схемного Окна
Показать все... | Преобразует изображение всей структурной схемы проекта в текущий размер Схемного Окна
Показать выделение | Изменяет выделенный фрагмент структурной схемы проекта в текущий размер Схемного Окна
Сетка | Включает/выключает режим Сетка в схемном окне
Кроме вышеуказанных, в Дополнительной панели инструментов расположена комбинированная кнопка, предназначенная для ручного масштабирования изображения в активном Схемном Окне. Числа, отображаемые в "окне" кнопки, приблизительно соответствует масштабу изображения структурной схемы в процентах.

(к содержанию)

1.7. "Линейка" типовых блоков

В программном комплексе "МВТУ" Библиотека типовых блоков состоит (условно) из Общетехнической и ряда Специализированных библиотек, доступ к которым осуществляется из "Линейки" типовых блоков, расположенной на экране монитора под Панелью инструментов ("линейкой" командных кнопок) см. рис. 1.6.

Рис. 1.6.

"Линейка" типовых блоков состоит из отдельных каталогов (библиотек), переключение которых осуществляется однократным щелчком левой клавиши "мыши" в поле "закладки" с соответствующим названием. Учитывая, что все "закладки" не умещаются по длине "Линейки" типовых блоков, в правом верхнем углу "Линейки" типовых блоков предусмотрены специальные кнопки, однократный щелчок левой клавишей "мыши" по которым смещает "закладки" вправо-влево на одну позицию.
Каждая из библиотек, включенная в "Линейку" типовых блоков, состоит из 2...22 блоков. Те библиотеки, которые не вмещаются по длине "Линейки", могут быть "прокручены" влево-вправо щелчками левой клавиши "мыши" по специальным кнопкам (в начале и конце "Линейки").
В учебных версиях ПК "МВТУ" "Линейка" типовых блоков состоит из 14-ти отдельных библиотек, сгруппированных, в основном, по функциональному признаку.
Общетехническая библиотека типовых блоков полностью входит в комплектацию любой версии ПК "МВТУ" и содержит следующие библиотеки:
- Источники входных воздействий (18 типовых блоков);
- Данные (9 типовых блоков);
- Операции математические (11 типовых блоков);
- Векторные операции (13 типовых блоков);
- Субструктуры (13 типовых блоков);
- Динамические звенья (14 типовых блоков);
- Нелинейные звенья (20 типовых блоков);
- Логические звенья (17 типовых блоков);
- Функции математические (20 типовых блоков);
- Ключи (10 типовых блоков);
- Дискретные звенья (9 типовых блоков).
В табл. 1.1 представлен состав Общетехнической библиотеки типовых блоков. Подробное описание блоков Общетехнической библиотеки и их математических моделей приведено в ПРИЛОЖЕНИИ "Библиотеки типовых блоков и их алгоритмы".
В типовую комплектацию учебных версий программного комплекса "МВТУ" обычно включены следующие Специализированные библиотеки типовых блоков:
- Кинетика нейтронов (3 типовых блока);
- Свойства (2 типовых блока);
- Статистика (9 типовых блоков).
Библиотеки Внешние (11 типовых блоков), Контроль и управление (12 имитаторов приборов и управляющих устройств) и Теплопроводность (4 типовых блока) включаются в ПК "МВТУ" по необходимости или по просьбе организации (вуза) или конкретного Пользователя, которые официально приобрели ПК "МВТУ" и зарегистрированы в базе данных Разработчика.
Кроме вышеуказанных в ПК "МВТУ" имеются и другие Специализированные библиотеки:
- Реакторные блоки;
- Логика АСУ ТП ВВЭР;
- Роботы;
- Элементы ПХГ (ПХГ - подземное хранилище газа).
Ряд фрагментов структурных схем, сформированных Разработчиком в процессе отладки ПК "МВТУ" и выполнения им прикладных НИР и ОКР, сохранена в отдельных каталогах в виде субмоделей (с расширением .sub). Фактически эти каталоги - дополнительные Специализированные библиотеки, из элементов которых стандартной процедурой Вставить субмодель из Дополнительного командного меню могут быть набраны значительные фрагменты новых структурных схем.

СОСТАВ ОБЩЕТЕХНИЧЕСКОЙ БИБЛИОТЕКИ ТИПОВЫХ БЛОКОВ

Таблица 1.1

Библиотека "Источники входных сигналов"
- Модельное время (часы)
- Константа
- Ступенчатое воздействие
- Многоступенчатое воздействие
- Произвольное кусочно-линейное воздействие
- Линейное воздействие
- Квадратичное воздействие
- Полиномное воздействие
- Гиперболическое воздействие
- Синусоидальное воздействие
- Экспоненциальное воздействие
- Нормальный шум
- Равномерный шум
- Пила
- Обратная пила
- Треугольное воздействие
- Меандр
- Текущий шаг интегрирования
Библиотека "Операции математические"
- Сумматор
- Умножение
- векторный сумматор
- векторное умножение
- Деление (скалярное/векторное)
- Модуль
- Знак
- Усиление
- Оператор "Case" числовой
- Интеграл от табличной функции
Библиотека "Векторные операции"
- Мультиплексор
- Демультиплексор
- Векторный размножитель скалярного сигнала
- Векторный размножитель векторных сигналов
- Распаковка матрицы входного сигнала
- Запаковка матрицы выходного сигнала
- Выборка из вектора входа
- Компенсатор начальных условий
- Решение системы ЛАУ
- Перемножение матрицы на вектор
- Транспонирование матрицы
- МНК - аппроксимация
- Интерполяция
Библиотека "Субструктуры "
- Макроблок
- Порт входа
- Порт выхода
- В память ("Передатчик")
- Из памяти ("Приемник")
- Стоп-расчет
- Заметка - Комментарий
- Общая память (3 блока)
- Система НАУ (2 блока)
- Внешние входы (2 блока)
Библиотека "Функции математические"
- Размножитель
- Линейная функция
- Квадратичная функция
- Полиномная функция
- Гиперболическая функция
- Экспонента
- Синус
- Обратные тригонометрические функции (4 блока)
- Гиперболические функции (4 блока)
- Степенная функция
- Показательная функция
- Показательнo-степенная функция
- Логарифм натуральный
- Логарифм десятичный 		Библиотека "Динамические звенья"
- Динамическое звено общего вида
- Идеальное интегрирующее звено
- Интегратор с насыщением
- Интегратор с изменяемыми начальными условиями
- Апериодическое звено 1-го порядка
- Колебательное звено
- Инерционно-интегрирующее звено
- Инерционно-дифференцирующее звено
- Инерционно-форсирующее звено
- Переменные состояния
- "Новый" блок
- Идеальное запаздывающее звено
- Апериодическое звено 1-го порядка (аналитика)
- Инерционно-дифференцирующее звено (аналитика)
Библиотека "Данные"
- Графическое окно 1 (временной график)
- Графическое окно 2 (фазовая плоскость)
- Графическое окно 3 (пространственный график)
- Запись в файл
- Считывание из файла (3 блока)
- Считывание из таблицы
Библиотека "Нелинейные звенья"
- Квадратичный функционал качества
- Линейное с насыщением
- Линейное с зоной нечувствительности
- Линейное с насыщением и зоной нечувствительности
- Релейное неоднозначное
- Релейная неоднозначная с зоной нечувствительности
- Зазор
- Люфт
- Излом
- Произвольная однозначная нелинейность
- Запоминание минимума
- Запоминание максимума
- Запоминание макс./мин. из 2-х скалярных сигналов
- Запоминание макс./мин. из N векторных сигналов
- Переменное транспортное запаздывание
- Дифференцирование
- Ограничение скорости изменения
- "Дельта" - функция
- Запоминание сигнала/время (2 блока)
Библиотека "Логические звенья"
- Универсальный блок булевой логики
- Логическое "И"
- Логическое "ИЛИ"
- Логическое "НЕ"
- Логическое "Равно"
- Логическое "Неравно"
- Логическое "Больше"
- Логическое "Больше-равно"
- Логическое "Меньше"
- Логическое "Меньше-равно"
- Xor / nxor
- Временное подтверждение
- М из N (событийная логика)
- Триггер
Библиотека "Ключи "
- Управляемый ключ (в режиме "on-line")
- Ключи амплитудные (4 блока)
- Ключи временные (4 блока)
- Ключ интегратора
Библиотека "Дискретные звенья"
- Задержка на шаг интегрирования
- Экстраполятор нулевого порядка
- Запаздывание дискретное
- Дифференцирование дискретное
- Разность нулевого порядка
- Передаточная функция общего вида
- Передаточная функция от обратного аргумента
- Переменные состояния
- ПИД- регулятор

(к содержанию)


Лабораторная работа N 1 часть 2. КРАТКОЕ ОПИСАНИЕ ПРОЦЕДУР РАБОТЫ В ПК "МВТУ"

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 1
часть 2
ИСПОЛЬЗОВАНИЕ ПРОГРАММНОГО КОМПЛЕКСА "МОДЕЛИРОВАНИЕ В ТЕХНИЧЕСКИХ УСТРОЙСТВАХ" (ПК "МВТУ") ДЛЯ АНАЛИЗА ДИНАМИКИ ЛИНЕЙНЫХ И ЛИНЕАРИЗОВАННЫХ САР, ОПИСЫВАЕМЫХ В ПЕРЕМЕННЫХ "ВХОД - ВЫХОД"

Москва, 2002 г.

Цель работы:

  • ознакомление с возможностями программного комплекса "МВТУ" версия 3.0;
  • освоение процедур формирования структурной схемы САР и ее параметров;
  • освоение процедур работы в режиме МОДЕЛИРОВАНИЕ, включая: выбор метода и параметров интегрирования; вывод данных расчета и т.п.;
  • формирование структурной схемы САР простейшей модели ядерного реактора, описываемой в переменных "вход-выход";
  • определение устойчивости САР ядерного реактора прямым моделированием переходных процессов при подаче управляющего и возмущающего воздействий.

2. КРАТКОЕ ОПИСАНИЕ ПРОЦЕДУР РАБОТЫ В ПК "МВТУ"

2.1. Основные этапы работы в среде ПК "МВТУ"

В данном подразделе рассматриваются только основные процедуры работы, освоение которых является обязательным условием для самостоятельной работы в среде программного комплекса.
Команды и опции выполняются либо посредством меню Главного Окна, либо посредством командных кнопок, назначение которых приведено в подразделах 1.5, 1.6.
Формирование, редактирование структурной схемы проекта (задачи), ввод параметров блоков, начальных условий, выбор метода и параметров интегрирования проводятся с использованием как специальных графических процедур, так и посредством команд или командных кнопок.
Структурную схему исследуемой задачи рекомендуется предварительно изобразить на черновике примерно в том же виде, в каком Вы желаете видеть ее на экране монитора.
Формирование структурной схемы и ее параметров, выбор метода, параметров интегрирования и т.п. целесообразно проводить в следующей последовательности:

  • используя "Линейку" типовых блоков заполните Схемное Окно необходимыми блоками примерно так же, как они должны быть расположены в структурной схеме;
  • используя процедуры "перетаскивания" блоков, изменения ориентации блоков и их размеров придайте структурной схеме "осмысленный" вид;
  • используя манипулятор типа "мышь", соедините блоки линиями связи;
  • двигаясь слева-направо и сверху-вниз (по блокам в Схемном Окне) задайте параметры блоков на структурной схеме (коэффициенты усиления, постоянные времени, начальные условия и т.д.);
  • используя кнопку Параметры расчета, задайте конечное время интегрирования, выберите необходимый метод интегрирования и другие параметры расчета;
  • сохраните набранную схему (проект) под оригинальным именем на жесткий диск (например, task_1. mrj или, например, proba. mrj);
  • запустите задачу на счет, смотрите текущие результаты в графических окнах и анализируйте ....
    • Рекомендуется выполнять процедуру сохранения на жесткий диск не в конце ввода всех условий задачи, а после каждого из вышеперечисленных этапов.
Первый этап - ввода структурной схемы (заполнение типовыми блоками) - можно начинать сразу после запуска программного комплекса в чистое Схемное Окно (создав его однократным щелчком левой клавиши "мыши" по командной кнопке Новый).

(к содержанию)

2.2. Демонстрационный пример по динамике САР ядерного реактора

Для быстрого ознакомления с математическими и сервисными возможностями ПК "Моделирование в технических устройствах" рассмотрим демонстрационный пример, в котором выполнено моделирование динамики САР ядерного реактора.
Войдите в среду WINDOWS, найдите Папку "МВТУ" и щелкните 2 раза левой клавишей манипулятора типа "мышь" (в дальнейшем просто "мышь"). Найдите пиктограмму "МВТУ_3_0", переместите курсор (стрелка) на нее и сделайте 2 щелчка левой клавишей "мыши" (проведен запуск ПК). Через 1...2 секундs на экране появится заставка ПК "МВТУ", а затем Главное Окно.
Переместите курсор на кнопку Открыть и щелкните 1 раз левой клавишей "мыши". Откроется диалоговое окно оболочки WINDOWS со списком всех файлов, имеющих расширение .mrj и расположенных в том же подкаталоге, где и основной исполняемый файл Мbty.exe. Откройте подкаталог DEMO\LAB_WORK, переместите курсор на строку reac_lab.mrj и щелкните левой клавишей, а затем переместите курсор на Открыть и снова нажмите на левую клавишу. Через несколько секунд произойдет заполнение Схемного Окна структурной схемой (см. рис. 2.1), а также откроется графическое окно с заголовком "Реактивности в долях b_эфф и относительные отклонения нейтронной мощности".
Проделав вышеописанное, Вы загрузили в оперативную память ПЭВМ задачу, соответствующую исследованию режима автоколебаний в релейном автоматическом регуляторе мощности реактора типа РБМК.
Сначала рассмотрим автономную САР (управляющее воздействие от Задатчика мощности равно нулю), которая выведена из состояния равновесия (начальная реактивность температурной обратной связи при t = 0 - ненулевая, а равна 1 % от (ßэфф ). Переместите курсор на кнопку [image] Старт в "линейке" командных кнопок и сделайте щелчок левой клавишей "мыши": задача будет инициализирована, о чем "сообщит" командная кнопка [image] Продолжить - рисунок пиктограммы (бегущий человек) станет темным. Переместите курсор на кнопку [image] Продолжить и выполните щелчок левой клавишей "мыши": начнется процесс моделирования в данной САР.

ЭКРАННАЯ КОПИЯ СХЕМНОГО ОКНА

Рис. 2.1

Полученные результаты свидетельствуют (см. графики переходного процесса в верхней части рис. 2.2), что в реакторе установился режим высокочастотных автоколебаний мощности (синяя кривая), амплитуда которых примерно в 2 раза превышает "уставку" по зоне нечувствительности в Управляющем реле ( 1 %). Причинами автоколебаний являются узкая зона нечувствительности в Управляющем реле, а также относительно высокая скоростная эффективность Привода СУЗ.
Процесс моделирования можно было реализовать не в два этапа (сначала кнопка [image] Старт, а затем кнопка [image] Продолжить), а в один, выполнив однократный щелчок левой клавишей "мыши" по кнопке [image] Продолжить.
Переместите курсор на блок Управляющее реле и сделайте 2-х кратный щелчок левой клавишей "мыши": откроется диалоговое окно этого блока (релейное неоднозначное с зоной нечувствительности). Инициализируйте 1-ю диалоговую строку (a1, a2, b1, b2, Y1, Y2) и измените параметры блока на более широкую зону нечувствительности, а именно: введите -0.02 -0.016 0.016 0.02 -1 1 (разделитель - пробел), что соответствует зоне нечувствительности по относительному отклонению нейтронной мощности ( ±2 %, коэффициенту возврата 0.8 и значению "скачка" при срабатывании реле ( ±1.0. Во второй диалоговой строке задается начальное состояние реле при t = 0: Y(0) = 0. Переместите курсор на кнопку Да и щелкните левой клавишей "мыши": диалоговое окно закроется. Снова запустите задачу на счет (по окончании расчета можно перемасштабировать графическое окно 2-х кратным щелчком левой клавиши "мыши" в поле графического окна). Характер поведения графиков с видетельствует (см. графики переходного процесса в нижней части рис. 2.2), что высокочастотных автоколебаний нет ( !!! ) и САР асимптотически возвращается в равновесное (стационарное) состояние.

КОПИИ ГРАФИЧЕСКИХ ОКОН

Рис. 2.2

Верните первоначальные значения параметров в 1-ой строке диалогового окна блока Управляющее реле (-0.01 -0.008 0.008 0.01 -1 1). Переместите курсор на блок Привод СУЗ и сделайте 2-х кратный щелчок левой клавишей "мыши": откроется диалоговое окно этого блока, являющегося типовым линейным динамическим эвеном, а именно: инерционно-интегрирующим. Инициализируйте поле ввода (диалоговую строку) коэффициента усиления К и введите меньшее значение: 1e-4.
Закройте диалоговое окно и запустите задачу на расчет. По окончании расчета перемасштабируйте графическое окно: высокочастотных автоколебаний не будет.
Рассмотрим неавтономную САР, которая до t <= 10 с находится в равновесии, а при t >10 с подается управляющее воздействие, которое должно перевести ядерный реактор на повышенный уровень мощности (+10 %). Переместите курсор на блок Обратная связь, сделайте 2-х кратный щелчок левой клавишей "мыши" и измените в открывшемся диалоговом окне начальное условие на нулевое. Закройте это диалоговое окно и переместите курсор на блок Задатчик мощности. Откройте его диалоговое окно и установите в диалоговой строке значения параметров 10 0 0.1 (через пробел), что соответствует следующему алгоритму работы этого блока: до t <= 10 с сигнал на выходе - нулевой, а при t >10 c на вход Главного сравнивающего устройства будет подано ступенчатое воздействие 0.1*1(t). Переместите курсор на командную кнопку [image] Параметры расчета и сделайте однократный щелчок левой клавишей "мыши". Измените Время интегрирования с 25 с на 100 с. Закройте это диалоговое окно, запустите измененную задачу на счет и по окончании расчета перемасштабируйте графические окна. Анализ полученных результатов (см. рис. 2.3) показывает, что ядерный реактор переведен на заданный уровень мощности (синяя кривая) с точностью до ширины зоны нечувствительности, регулирующий стержень внес дополнительную положительную реактивность ~ 6...7 % от (ßэфф (красная кривая), а реактивность ядерного реактора в переходном процессе в максимуме достигает ~ 6 % от (ßэфф (розовая кривая) и стремится к нулю при t ->беск.

ПАРАМЕТРЫ САР ПРИ ПЕРЕХОДЕ НА ПОВЫШЕННЫЙ УРОВЕНЬ МОЩНОСТИ

Рис. 2.3

Просмотрите диалоговые окна других блоков данной задачи (можно вызвать справку по любому блоку нажав комбинацию клавиш Сtrl+F1). Отметим, что для отображения результатов расчета использована векторизованная обработка сигналов: сигналы реактивностей регулирующего стержня и реактора посредством мультиплексора "свернуты" в один векторный сигнал (2-жильный), а затем, используя типовой блок Усилитель, векторно нормированы на значение эффективной доли запаздывающих нейтронов (ßэфф. Типовой блок Временной график в данной задаче имеет 2 входа (1-й вход - векторный, 2-ой - скалярный). "Нюансы" и особенности других блоков найдите сами....
Посредством системной кнопки в левом верхнем угле Схемного Окна закройте данную задачу, ответив на запрос о сохранении текущего проекта (задачи) - No.
Проделав процедуры, аналогичные описанным в данном подразделе, Вы можете просмотреть и другие демонстрационные примеры. Все примеры полностью готовы к демонстрации и запускаются также, как и рассмотренный выше пример...

(к содержанию)

2.3. Демонстрационно-ознакомительная задача

2.3.1. Исходные данные для ознакомительной задачи

Для приобретения навыков самостоятельной работы в среде программного комплекса "МВТУ" выполним все этапы, рекомендованные в подразделе 2.1, применительно к моделированию динамики САР, структурная схема которой приведена на рис. 2.4.

СТРУКТУРНАЯ СХЕМА САР

Рис. 2.4

Объект управления с передаточной функцией W2 (s), соответствует типовому звену (колебательному) с параметрами: k2 = 1.0; T2 = 1 c; параметр демпфирования b = 0.5; начальные условия - нулевые.
Местная обратная связь с передаточной функцией W3 (s), соответствует типовому звену - апериодическому 1-го порядка с параметрами: k3 = 0.6; T3 = 5 c.
Локальное сравнивающее устройство обеспечивает отрицательную обратную связь, т.е. "работает" в режиме обычного вычитания.
Необходимо подобрать коэффициент усиления k1 интегрирующего регулятора (W1(s)) таким образом, чтобы при подаче ступенчатого управляющего воздействия u(t) = 0.8(1(t) перерегулирование отсутствовало (т.е. ymax <= 0.8) и время переходного процесса не превышало 20 с.
Для отображения результатов расчета использовать типовой блок библиотеки Данные - Временной график.

(к содержанию)

2.3.2. Ввод структурной схемы и исходных данных

Ввод структурной схемы и исходных данных выполним в последовательности, рекомендованной в подразделе 2.1.
Этап 1 - заполнение Схемного окна необходимыми типовыми блоками.
Убедитесь, что все демонстрационные примеры, которыми Вы просматривали в подразделе 2.2 закрыты и Схемное Окно отсутствует. Переместите курсор на кнопку [image] Новый и сделайте однократный щелчок левой клавишей "мыши": откроется чистое Схемное Окно. Переместите курсор на "закладку" Источники входных воздействий и щелкните 1 раз левой клавишей "мыши": Вы инициализировали соответствующую библиотеку типовых блоков. Переместите курсор на блок Ступенчатое воздействие (подпись Ступенька) и сделайте однократный щелчок левой клавишей "мыши": фон блока в "Линейке" изменился. Это означает, что блок можно "переносить" в Схемное Окно. Переместите курсор в верхний левый угол Схемного Окна и щелкните 1 раз левой клавишей "мыши": в поле Схемного Окна появился переносимый блок.
Переместите курсор на "закладку" Операции математические и выполните однократный щелчок левой клавишей "мыши": Вы инициализировали соответствующую типовую библиотеку. Переместите курсор на блок Сравнивающее устройство и сделайте однократный щелчок: фон блока изменился. Переместите курсор в поле Схемного Окна на место, где Вы желали бы расположить Главное сравнивающее устройство и щелкните 1 раз левой клавишей "мыши": перенос блока Сравнивающее устройство в Схемное Окно выполнен. Повторите вышеописанные действия и перенесите на свободное место в Схемном Окне (ниже и левее) и 2-ой блок Сравнивающее устройство, необходимый для моделирования Локального сравнивающего устройства.
Переместите курсор на "закладку" Динамические звенья, инициализируйте ее, перенесите требуемые блоки (Интегратор, Апериодическое и Колебательное звенья) в Схемное Окно по вышеописанной процедуре приблизительно на желаемые места.
Выполните последний перенос блока в Схемное Окно: переместите курсор на "закладку" Данные, инициализируйте данную библиотеку типовых блоков, перенесите блок Временной график в Схемное Окно примерно на желаемое место.
Наконец, переместите курсор на крупную кнопку в левой части "Линейки" типовых блоков и сделайте однократный щелчок: Вы временно "отключили" процедуру переноса блоков в схемное окно.

Этап 2 - проведение линий связи на структурной схеме.
Переместите курсор на один из блоков Сравнивающее устройство (будущее Главное сравнивающее устройство), нажмите на левую клавишу "мыши" и не отпуская ее "перетащите" этот блок так, чтобы его верхний входной порт (в дальнейшем просто вход) по горизонтали был на одном уровне с выходным портом блока Управляющее воздействие.
Для упрощения этой процедуры рекомендуется включить опцию Сетка в Схемном Окне.
Опция Сетка может быть включена 3-мя способами:
- переместите курсор на кнопку Сетка в Дополнительной панели инструментов и выполните однократный щелчок левой клавиши "мыши";
- переместите курсор на свободное место в Схемном Окне и сделайте однократный щелчок правой клавишей "мыши": "всплывет" Дополнительное командное меню в котором необходимо сделать щелчок левой клавишей "мыши" по строке Сетка;
- нажмите клавишу F4 при активном Схемном Окне.
Далее, переместите курсор на выходной порт блока Управляющее воздействие, сделайте щелчок левой клавишей "мыши" и, отпустив клавишу, "протяните" горизонтальную линию связи к верхнему входному порту Главного сравнивающего устройства. Снова сделайте однократный щелчок левой клавишей: на верхнем входе появится типичная входная стрелка. Если Вы сделали щелчок левой клавишей раньше, чем проводимая связь вошла "в притяжение" входного порта, дотяните линию связи до соответствующего входного порта и сделайте щелчок левой клавишей "мыши".
Если требуется сделать поворот на (± 90 градусов в линии связи, выполните щелчок левой клавишей "мыши" и продолжайте проведение линии связи в новом направлении.
Если Вы желаете прервать процедуру проведения линии связи (например, по причине внешнего вида - "некрасивая"), нажмите клавишу Shift и, не отпуская ее, сделайте щелчок левой клавишей "мыши": линия оборвется. Далее можно удалить эту линию: выделите ее (щелчок левой клавишей "мыши" по линии) и затем удалите линию с помощью командной кнопки [image] Вырезать (пиктограмма "ножницы").
С использованием аналогичных процедур уточните расположение блоков в прямой цепи структурной схемы (W1 (s), Локальное сравнивающее устройство и W2 (s)) и проведите линии связи.
Переместите курсор на блок с W3 (s), нажмите на клавиатуре клавишу Shift и не отпуская ее нажмите 1 раз левую клавишу "мыши": порты блока повернутся на 90 градусов против часовой стрелки. Повторите эту процедуру еще 1 раз: ориентация блока станет справа-налево. Уточните расположение блока с W3 (s), используя процедуру "перетаскивания" блоков в Схемном Окне. Проведите линии связи от блока с W2 (s) к блоку с W3 (s) и далее от него к 2-му (нижнему) входному порту Локального сравнивающего устройства.
Переместите курсор на линию связи от блока с W2 (s) к блоку с W3 (s) (предпочтительнее на угол последнего поворота линии связи), нажмите на клавиатуре клавишу Ctrl и, не отпуская ее, сделайте щелчок левой клавишей "мыши": появится темная точка. Отпустив обе клавиши, проведите линию связи вниз (малой длины): Вы получили "ответвление" от существующей линии связи (сравните с рис. 2.4). Используя вышеописанные процедуры, продлите линию Главной обратной связи до 2-го входного порта Главного сравнивающего устройства.
Переместите блок Временной график, сделайте "ответвление" от Главной обратной связи и продлите его до входа в блок Временной график (см. рис. 2.4).
Сохраните введенную часть задачи. Для этого откройте меню Файл в Главном Окне, переместите курсор на опцию Сохранить как... и сделайте однократный щелчок левой клавишей "мыши": в появившемся диалоговом окне инициализируйте строку ввода и наберите оригинальное имя Вашей задачи, например, mvtu_lab.mrj (расширение может быть любым, необязательно .mrj). Закройте окно Сохранение проекта, щелкнув по кнопке ОК.
Переместите курсор на левый нижний угол окантовки Схемного Окна (появится специальная наклонная двухсторонняя стрелка) и измените размер Схемного Окна так, чтобы правое и нижнее поля составляли не менее 4...5 сантиметров.
Если набранная структурная схема не "вписалась" в размеры Схемного Окна, переместите курсор на кнопку [image] Показать все в Дополнительной панели инструментов и сделайте однократный щелчок левой клавишей "мыши": произойдет перемасштабирование структурной схемы и она станет наблюдаемой в Схемном Окне полностью.
Снова сохраните задачу, щелкнув левой клавишей "мыши" по кнопке [image] Сохранить.

Этап 3 - ввод параметров структурной схемы.
Переместите курсор на блок Управляющее воздействие и сделайте 2-х кратный щелчок левой клавишей "мыши": откроется диалоговое окно этого блока с активной "закладкой" Параметры (см. рис. 2.5).

Рис. 2.5

Инициализируйте диалоговую строку, введите через пробел 0 0 0.8 (3 числа) и нажмите на кнопку Да. Повторите аналогичные процедуры для блоков с W2 (s) и W3 (s) и введите соответствующие значения k, T и начальных условий.
"Закладка" Входы позволяет изменять расположение входных портов (см. рис. 2.6), а "закладка" Выходы - изменять расположение выходных портов.

Рис. 2.6

"Закладка" Общие (см. рис. 2.7) позволяет:
- изменять имя блока (начинающему Пользователю лучше это не делать);
- ввести в специальном поле Заголовок поясняющую подпись под блоком;
- посредством опции Цвет изменять цвет фона блока;
- посредством опции Шрифт изменять тип и цвет шрифта подписи под блоком;
- посредством опции Пароль "засекречивать" параметры типового блока (деактивируется закладка Параметры), а для блока Субмодель посредством опции Пароль "закрывать" нежелательный доступ к внутренней структуре субмодели.

Рис. 2.7

Примечание. Диалоговое окно любого типового блока можно открыть и другим способом. Переместите курсор на редактируемый блок и выполните однократный щелчок правой клавишей "мыши": появится "всплывающее" меню блока (см. рис. 2.8), однократный щелчок левой клавишей "мыши" по строке Свойства которого вызывает диалоговое окно блока. Опции "всплывающего" меню блока Вырезать и Копировать дублируют одноименные кнопки Дополнительного командного меню, а неактивная на рис. 2.8 опция Сохранить субмодель включается только при щелчке правой клавишей "мыши" по блоку Субмодель.

СХЕМНОЕ ОКНО С "ВСПЛЫВАЮЩИМ" МЕНЮ БЛОКА

Рис. 2.8

Вернемся к вводу параметров структурной схемы. Откройте диалоговое окно Главного сравнивающего устройства и убедитесь, в диалоговой строке уже введены необходимые параметры (по умолчанию): 1 (плюс 1) и -1 (минус 1) (через пробел). При моделировании блок Сравнивающее устройство реализует алгебраическое сложение двух сигналов в соответствии с введенными весовыми коэффициентами, т.е. 1-ый - с весовым коэффициентом 1 (+1), а 2-ой - с весовым коэффициентом -1 (минус 1).
Если необходимо алгебраически сложить 3 сигнала, например, с весовыми коэффициентами 0.8, -1.2 и 2.5, то в строке ввода необходимо ввести соответствующие параметры (через пробел: 0.8 -1.2 2.5). При закрытии диалогового окна блока Сравнивающее устройство произойдет "перерисовка" этого блока и он будет иметь 3 входных порта, где верхний левый входной порт (при ориентации блока слева-направо) - для 1-го сигнала (коэффициент равен 0.8), нижний вход - для 2-го сигнала (коэффициент равен -1.2) и нижний левый вход - для 3-го сигнала (коэффициент равен 2.5). Повторите аналогичные процедуры для Локального сравнивающего устройства.
Главное сравнивающее устройство и Локальное сравнивающее устройство можно реализовать и с использованием типового блока Сумматор из библиотеки Операции математические, поскольку алгоритм работы этого блока идентичен алгоритму блока Сравнивающее устройство, а различие - только в пиктограммах блоков и в расположении 2-го входного порта. Убедитесь в этом сами...
Откройте диалоговое окно блока с W1 (s), введите "прикидочное" значение коэффициента усиления k1 = 1. Начальное условие уже установлено (по умолчанию). Закройте диалоговое окно.
Снова сохраните задачу, щелкнув по командной кнопке [image] Сохранить.

Этап 4 - установка параметров интегрирования.
Переместите курсор на командную кнопку [image] Параметры расчета и сделайте однократный щелчок левой клавишей "мыши": откроется диалоговое окно Параметры интегрирования с активной "закладкой" Основные (см. рис. 2.9).
Другие "закладки" этого диалогового окна предназначены:

  • "закладка" Дополнительные - для установки "тонких" параметров расчета (начинающий Пользователь может оставить значения в полях этой закладки, установленные "по умолчанию");
  • "закладка" Скорость - для расчета в заданном масштабе времени (при включенном Режиме масштабирования времени значение 1 в поле Множитель ускорения соответствует расчету в реальном масштабе времени);
  • "закладка" Архивация - для сохранения в бинарном формате (файл с расширением .rez) всех данных расчета, которые могут быть использованы для ускоренного воспроизведения процесса моделирования посредством опции Эмуляция расчета из файла в меню Моделирование;
  • "закладка" Рестарт - для периодического (например, через 1 секунду) сохранения в бинарном формате (файл с расширением .rst) основных данных расчета, по которым можно продолжить процесс моделирования после завершения расчета;
  • "закладка" Сеть - для реализации режима Расчета на удаленном сервере.

Рис. 2.9

Режим Расчет на удаленном сервере реализуется в сетевом варианте работы ПК "МВТУ". На компьютере-клиенте Пользователь формирует структурную схему задачи, задает параметры блоков структурной схемы, задает метод и параметры интегрирования. После этого "клиентский" вариант ПК "МВТУ" (типовая версия ПК или графическая оболочка ПК без расчетного ядра) формирует исходные данные о моделируемой задаче, которые по одному из сетевых протоколов (например, TCP/IP) передаются на компьютер-сервер (имеющий только расчетное ядро), где и происходит непосредственный расчет динамического режима. Результаты расчета по тому же сетевому протоколу передаются обратно на компьютер-клиент, где происходит отображение результатов расчета и их последующий анализ....
Вернемся к этапу установки основных параметров интегрирования. При активной "закладке" Основные выберите численный метод, например, Адаптивный 1. Далее введите: Время интегрирования- 40 (секунд); Минимальный шаг интегрирования - 0.001 (сек.); Максимальный шаг интегрирования - 0.1 (сек.); Число точек вывода - 400. Параметр точности можно оставить тем же (по умолчанию 0.001). Закройте диалоговое окно, щелкнув левой клавишей "мыши" по кнопке Да.
Снова сохраните задачу (кнопка [image] Сохранить).

Этап 5 - оформление поясняющих подписей.
Выполним оформление Схемного Окна, как это сделано на рис. 2.4. Переместите курсор под блок Управляющее воздействие и сделайте 2-х кратный щелчок левой клавишей "мыши": появится временное окно для ввода текста. Переместите курсор в это окно, сделайте щелчок левой клавишей " мыши" и затем введите заголовок данного блока (в две строки). Переместите курсор на свободное место в Схемном Окне и сделайте 2-х кратный щелчок левой клавишей "мыши": временное окно закроется и под блоком появится желаемая подпись. Если подпись получилась "некачественной" (с ошибками), снова откройте временное окно для ввода текста (2-х кратный щелчок левой клавишей "мыши" по тексту под блоком) и, используя клавиши редактирования (Backspace, Del и др.), скорректируйте подпись.
Подпись под блоком можно выполнить и другим способом, а именно: как это показано на рис. 2.7...
Интерфейс ПК "МВТУ" позволяет изменить в подписи тип, размер и цвет шрифта. Выделите блок, откройте меню Стиль и выберите опцию Шрифт подписи блока. Откроется диалоговое окно Выбор шрифта, в котором Вы можете установить желаемые параметры подписи, например: шрифт - MS Sans Serif; начертание - Полужирный; цвет - Красный; размер - 8. При закрытии окна Выбор шрифта (щелчок по кнопке ОК) происходит автоматический возврат в среду ПК "МВТУ".
Используя меню Стиль и его опции, можно изменить фон блока, фон всего Схемного Окна, цвет линий связи (выделив предварительно редактируемый блок или линию связи однократным щелчком левой клавиши "мыши"). Выполните цветовое оформление структурной схемы самостоятельно...
Также самостоятельно выясните назначение опций других опций в меню Стиль...
Выполнив вышеописанные процедуры для всех блоков, а также отключив опцию Рисовать обрамление, придайте введенной структурной схеме вид, близкий рис. 2.4.
Сохраните введенные изменения, используя командную кнопку [image] Сохранить.

Этап 6 - открытие Графического окна и изменение его размеров.
Переместите курсор на блок График y(t), сделайте однократный щелчок правой клавишей "мыши" и во "всплывающем" меню блока левой клавишей "мыши" выберите строку Свойства. Первая строка (Число входов) в диалоговом окне не требует редакции, т.к. в ней по умолчанию введено значение 1. Переместите курсор на поле ввода 2-ой диалоговой строки (Вывод на каждом шаге), в которой по умолчанию введено Нет, и выполните однократный щелчок левой клавишей "мыши": в поле ввода появится специальная кнопка. Щелкнув по этой кнопке левой клавишей "мыши", Вы имеете возможность выбора: Нет или Да.
Если Вы выбрали Да, то при выполнении моделирования в графическом окне будут отображаться все изменения линии графика после каждого шага интегрирования, а если Вы выбрали Нет, то при выполнении моделирования в графическом окне будут отображаться изменения линии графика через временной интервал, равный приблизительно отношению Времени интегрирования к Числу точек вывода (см. диалоговое окно Параметры интегрирования).
В 3-ей строке диалогового окна (Прореживание точек) по умолчанию введено Да. Если необходимо иметь информацию о всех расчетных данных, выводимых на график, то Вы должны в поле ввода 3-ей диалоговой строки изменить Да на Нет.
Заметим, что если в 3-ей диалоговой строке введено Да, то в обоих вариантах заполнения 2-ой диалоговой строки (Нет или Да) отображаемые данные подвергаются прореживанию по следующему алгоритму: если 3 последовательные расчетные точки лежат на одной прямой (с заданной точностью), то средняя точка не отображается на графике, т.к. отрезок, проведенный через 1-ю и 3-ю точки содержит и 2-ю точку.
Закройте диалоговое окно блока Временной график (щелчок по кнопке Да) и выполните 2-х кратный щелчок левой клавишей мыши по изображению этого блока в Схемном окне: откроется графическое окно с заголовком График y(t). Если заголовок графического окна будет другим, то закройте графическое окно (щелчок "мышью" по системной кнопке в верхнем правом угле графического окна) и снова откройте его... Для переноса графического окна в другое место необходимо переместить курсор на его заголовок, нажать левую клавишу "мыши" и, не отпуская ее, "перетащить" окно в желаемое место. Изменение его размеров производится также, как и для любых других окон в среде WINDOWS. Используя процедуры изменения размеров окон, придайте графическому окну необходимый размер (~ 1/4 от площади от Схемного Окна).
Установку других параметров графического окна выполним после проведения процесса моделирования переходных процессов..
. Сохраните введенные изменения, используя командную кнопку [image] Сохранить.

(к содержанию)

2.3.3. Моделирование переходных процессов и вариантные расчеты

Переместите курсор на командную кнопку [image] Продолжить и щелкните левой клавишей "мыши": Вы запустили созданную задачу на счет. По окончании расчета появится специальное окно Сообщения с информацией: "Ошибка: Заданная точность не обеспечивается".
Перемасштабируйте графическое окно 2-х кратным щелчком "мыши". Переместите курсор на кнопку Параметры расчета и измените минимальный шаг интегрирования на новое значение (1e-10) и повторите процесс моделирования.
Данные расчета показывают, что, во-первых, внешне вид переходного процесса не изменился при резком уменьшении минимального шага интегрирования, так как при первоначальном минимальном шаге интегрирования (0.001) заданная точность не обеспечивалась только на 1-ом шаге моделирования (т.е. при отработке ступенчатого воздействия). Поэтому сообщение о точности можно было проигнорировать... Во-вторых, данные расчета свидетельствуют, что при k1 = 1 исходная САР неустойчива и переходной процесс расходящийся (см. ниже по тексту рис. 2.12).
Выполним прерванные в подразделе 2.3.2 процедуры редактирования графического окна. Переместите курсор в центральную часть графического окна и сделайте однократный щелчок правой клавишей "мыши": появится командное меню графического окна (см. рис. 2.10).

Рис. 2.10

Ряд опций командного меню блока Временной график общеприняты и не требуют особых пояснений (Автомасштаб, Курсор, Всегда впереди).
Опция Список заменяет графическое изображение на таблицу данных. Возврат к графическому изображению осуществляется щелчком правой клавиши "мыши" в поле таблицы и последующим выбором в меню опции Список.
Опция Копировать реализует операцию копирования изображения графика в буфер для последующей вставки в соответствующие отчетные документы, например, в текстовые документы WINWORD...
Щелкните левой клавишей "мыши" по строке Свойства: откроется специальное диалоговое окно, имеющее заголовок Настройка (см. рис. 2.11).

Рис. 2.11

Переместите курсор в диалоговое поле Заголовок и введите новое название График переходного процесса при К=1. Первые 3 кнопки в строке Заголовок предназначены для "привязки" текста заголовка (по левому краю, по центру, по правому краю), а последняя (пиктограмма с буквами) - для задания параметров шрифта заголовка графика.
Аналогичным образом дополните подпись под осью X (правое диалоговое поле Метка): Время, с. Затем сотрите подпись (Переменная) для оси Y в левом диалоговом поле Метка и введите новую подпись: y(t). Кнопки в обеих строках Метка предназначены для "привязки" текста подписей по осям графика (первые 3 кнопки) и для задания параметров шрифта этих подписей (крайняя правая кнопка).
Посредством диалогового окна Настройка можно изменять: цвет и тип линии; цвет и тип линии сетки на графике; цвет поля графика и окантовки.
Переместите курсор на верхнюю цветную кнопку, щелкните 1 раз левой клавишей "мыши" и левой клавишей "мыши" выберите новый цвет линии (FG), например синий, а правой клавишей - цвет поля графика (BG), например, белый.
Щелкнув по цветной кнопке в колонке Ось Х установите левой клавишей "мыши" цвет сетки по оси абсцисс (FG), например, серый, а правой клавишей "мыши" - цвет окантовки графика (BG), например, белый. Повторите вышеописанные действия и измените цвет сетки по оси ординат (колонка Ось Y) тоже на серый.
Самостоятельно ознакомьтесь с возможностями редактирования графика посредством других опций диалогового окна Настройки...
Закончив процедуры редактирования параметров графического окна, переместите курсор на кнопку Да и закройте данное диалоговое окно. Графическое окно будет иметь вид, подобный рис. 2.12.
Измените значение k1 на новое: 0.2. Повторите процесс моделирования, перемасштабируйте окно графиков по окончании расчета. Данные свидетельствуют, что хотя перерегулирование и отсутствует, но время переходного процесса значительно превышает 20 секунд. Если Вы измените в диалоговом окне графического окна значение К в названии графика, то графическое окно с данными расчета будет иметь вид, подобный рис. 2.13.

Рис. 2.12

Рис. 2.13
Снова измените значение k1 на новое: 0.35. Повторите вышеописанные процедуры. Анализ полученных данных показывает, что Вы добились требуемых характеристик переходного процесса: перерегулирование - отсутствует; время входа в 5-ти процентную "трубку" не превышает 20 секунд (см. рис. 2.14).

Рис. 2.14

Демонстрационно-ознакомительная задача завершена. Сохраните задачу на диск...
Сформированная структурная схема САР (см. рис. 2.4) ниже будет использована для освоения процедур других режимов работы программного комплекса "МВТУ", а именно: режима АНАЛИЗ, а в следующем семестре - режима ОПТИМИЗАЦИЯ.

(к содержанию)

3. САМОСТОЯТЕЛЬНОЕ ИССЛЕДОВАНИЕ САР ЯДЕРНОГО РЕАКТОРА ПРЯМЫМ МОДЕЛИРОВАНИЕМ ПЕРЕХОДНЫХ ПРОЦЕССОВ

Выполненную выше демонстрационно-ознакомительную задачу, целью которой являлось ускоренное освоение основных процедур работы в среде ПК "МВТУ" (режим МОДЕЛИРОВАНИЕ), дополним "более серьезным" заданием, а именно: формирование структурной схемы простейшей математической модели динамики САР ядерного реактора и определение некоторых динамических свойств САР (включая и устойчивость САР) прямым моделированием переходных процессов при подаче управляющих и возмущающих воздействий.
Структурная схема математической модели динамики САР ядерного реактора (в дальнейшем часто будем использовать сокращенное название - САР ЯР) в данной лабораторной работе имеет много общего со структурной схемой САР, которую Вам предстоит сформировать и исследовать в домашнем задании по курсу "Управление в технических системах", поэтому настоящую лабораторную работу можно рассматривать как одну из "репетиций" домашнего задания...
Структурная схема САР ЯР имеет примерно следующий вид:

Рис. 3.1

где:
- нормированное отклонение управляющего напряжения в обмотке возбуждения электродвигателя;
- нормированное отклонение плотности нейтронов (мощности или нейтронного потока);
- реактивность, вносимая в реактор регулирующим стержнем, внешним возмущающим воздействием, местной (внутренней) обратной связью, соответственно;
- рассогласование (ошибка).
Для изображения двух блоков в структурной схеме на рис. 3.1 использована пиктограмма в виде вопросительного знака. Это означает, что для описания динамики этих блоков сначала необходимо определить вид каждой передаточной функции и затем решить, какое типовое звено (или звенья!?) использовать....
Для изображения на рис. 3.1 блока Кинетика нейтронов использована пиктограмма типового блока W(s) общего вида (из библиотеки Динамические звенья), что можно рассматривать как "подсказку" о том, какой типовой блок из библиотек ПК "МВТУ" необходимо использовать для описания кинетики нейтронов в этой задаче...
На рис. 3.1 "случайно" не изображен ряд блоков, например, блоков графического отображения результатов расчета и блоков преобразования сигналов. Каких блоков из библиотек Данные, Операции..., Функции... не хватает - определите самостоятельно...
Учитывая, что в процессе моделирования Вам необходимо будет построить зависимости N(t)/No , T(t), d[(ст(t)/(эфф]/dt, а также на одном графике реактивности [image] в долях (ßэфф в зависимости от модельного времени, Вы должны самостоятельно найти способы формирования и отображения этих динамических переменных...
Известно (например, из лекций по курсу "Управление в технических системах"), что переход к нормированным отклонениям плотности нейтронов (что эквивалентно нормированным отклонениям мощности или нейтронного потока) и последующая линеаризация дифференциального уравнения для плотности нейтронов, позволяют представить математическую модель точечной кинетики нейтронов с одной эффективной группой запаздывающих нейтронов в следующем виде:

(3.1)

где (ßэфф - эффективная доля запаздывающих нейтронов; l - время жизни мгновенных нейтронов; [image] - постоянная распада ядер-предшественников запаздывающих нейтронов; [image] - нормированные отклонения концентрации ядер-предшественников запаздывающих нейтронов.
Местная обратная связь, определяемая отрицательным температурным эффектом реактивности, описывается следующими уравнениями:

(3.2)

где:
 | - температурный коэффициент реактивности;
 | - стационарная температура топлива в активной зоне и нормированное отклонение температуры топлива в активной зоне от стационара, соответственно;
 | - постоянная времени (инерционность) топлива в активной зоне;
А | - безразмерный коэффициент.
Привод регулирующего стержня (см. рис. 3.1) состоит из электродвигателя постоянного тока, редуктора, муфт, преобразователя движения, непосредственно регулирующего стержня и т.п., однако для упрощения задачи все эти элементы объединены в одно звено.
Нестационарные процессы в блоке (в звене) Привод регулирующего стержня описываются следующим дифференциальным уравнением:

(3.3)

где: Кпр - коэффициент скоростной эффективности Привода регулирующего стержня;
- постоянная времени (инерционность) Привода регулирующего стержня.

Для выполнения самостоятельной части лабораторной работы каждой подгруппе необходимо выполнить следующие этапы:

  • представить динамику САР в переменных "вход-выход" (в передаточных функциях), определив вид передаточных функций для всех блоков (звеньев) структурной схемы;
  • подставить численные значения всех параметров (ß, [image], [image], То , А, [image], l , [image] , Кпр и т.д.) и вычислить значения всех коэффициентов в полиномах числителей и знаменателей передаточных функций;
  • используя освоенные процедуры работы в среде ПК "МВТУ", сформировать структурную схему динамики САР ядерного реактора, внешний вид которой должен быть лишь приблизительно (а может и "отдаленно") похожим на рис. 3.1;

    Не забудьте, что при моделировании переходных процессов Вам необходимо построить зависимости: N(t)/N0, T(t), d[rст(t)/ßэфф]/dt, а также на одном графике реактивности в долях (ßэфф в зависимости от времени. Поэтому, Вы должны самостоятельно найти способы формирования и отображения этих динамических переменных в Графических окнах...
  • представить сформированную структурную схему (с введенными значениями параметров звеньев, блоков формирования и отображения сигналов) преподавателю для проверки ее корректности...
  • выполнить "пробное" моделирование переходного процесса в исходной САР при отсутствии возмущающего воздействия и подаче управляющего воздействия u(t) = 0.05×1(t) для конечного времени моделирования tкон = 40 с, и на основании вида переходных процессов сделать вывод об устойчивости исходной САР и предложить способ последующей коррекции САР посредством изменения ее параметров (каких ??? - согласовать с преподавателем);
  • методом последовательных приближений достичь устойчивости САР;
  • выполнить моделирование переходного процесса в скорректированной САР при отсутствии возмущающего воздействия и подаче управляющего воздействия u(t) = 0.05×1(t) для конечного времени моделирования tкон = 400 с, и на основании результатов расчета (по графикам) выполнить анализ поведения отображаемых динамических переменных;
  • выполнить моделирование переходных процессов в скорректированной САР при отсутствии управляющего воздействия u(t) и подаче возмущающих воздействий [image] (поочередно) для конечного времени моделирования tкон = 100 с, и на основании результатов расчета (по графикам) выполнить анализ поведения отображаемых динамических переменных.
  • выполнить моделирование переходных процессов при подаче вышеуказанных возмущающих воздействий для нового значения температурного коэффициента реактивности a = 5· 10-5 K-1, и на основании результатов расчета (по графикам) выполнить анализ поведения отображаемых динамических переменных.

Исходные данные:

ßэфф = 0.006, l = 0.072 с-1
tпр =  0.2 с-1;
T0   = 700
K, A = 0.75, a = 1· 10-4 K-1

Внимание. Ряд параметров [image] одинаковы для всех подгрупп, а значения параметров [image] будут заданы преподавателем индивидуально для каждой подгруппы.

(к содержанию)